Bug 565165 - FTBFS atomix-2.14.0-7.1: ImplicitDSOLinking
FTBFS atomix-2.14.0-7.1: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: atomix (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 13:07 EST by FTBFS
Modified: 2010-02-13 15:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-13 15:10:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
root.log (1.09 MB, text/plain)
2010-02-13 13:07 EST, FTBFS
no flags Details
build.log (57.50 KB, text/plain)
2010-02-13 13:07 EST, FTBFS
no flags Details
mock.log (949 bytes, text/plain)
2010-02-13 13:07 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 13:07:02 EST
atomix-2.14.0-7.1.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 13:07:05 EST
Created attachment 393905 [details]
root.log

root.log for x86_64
Comment 2 FTBFS 2010-02-13 13:07:07 EST
Created attachment 393906 [details]
build.log

build.log for x86_64
Comment 3 FTBFS 2010-02-13 13:07:08 EST
Created attachment 393907 [details]
mock.log

mock.log for x86_64
Comment 4 Thorsten Leemhuis 2010-02-13 15:10:35 EST
fixed by 2.14.0-8.1

Note You need to log in before you can comment on or make changes to this bug.