Bug 565174 - FTBFS notecase-1.6.1-6.fc12: ImplicitDSOLinking
Summary: FTBFS notecase-1.6.1-6.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: notecase   
(Show other bugs)
Version: 13
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Martin-Gomez Pablo
QA Contact: Fedora Extras Quality Assurance
URL: http://linux.dell.com/files/fedora/Fi...
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 564245 583278
TreeView+ depends on / blocked
 
Reported: 2010-02-13 18:08 UTC by FTBFS
Modified: 2010-08-20 01:30 UTC (History)
1 user (show)

Fixed In Version: notecase-1.6.1-9.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 01:30:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (551.38 KB, text/plain)
2010-02-13 18:08 UTC, FTBFS
no flags Details
build.log (88.96 KB, text/plain)
2010-02-13 18:08 UTC, FTBFS
no flags Details
mock.log (955 bytes, text/plain)
2010-02-13 18:08 UTC, FTBFS
no flags Details
root.log (788.85 KB, text/plain)
2010-02-13 18:08 UTC, FTBFS
no flags Details
build.log (88.43 KB, text/plain)
2010-02-13 18:08 UTC, FTBFS
no flags Details
mock.log (963 bytes, text/plain)
2010-02-13 18:08 UTC, FTBFS
no flags Details
Fix for notecase FTBFS (315 bytes, text/plain)
2010-05-12 15:14 UTC, Charley Wang
no flags Details

Description FTBFS 2010-02-13 18:08:42 UTC
notecase-1.6.1-6.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)

Comment 1 FTBFS 2010-02-13 18:08:45 UTC
Created attachment 393956 [details]
root.log

root.log for i386

Comment 2 FTBFS 2010-02-13 18:08:47 UTC
Created attachment 393957 [details]
build.log

build.log for i386

Comment 3 FTBFS 2010-02-13 18:08:48 UTC
Created attachment 393958 [details]
mock.log

mock.log for i386

Comment 4 FTBFS 2010-02-13 18:08:50 UTC
Created attachment 393959 [details]
root.log

root.log for x86_64

Comment 5 FTBFS 2010-02-13 18:08:51 UTC
Created attachment 393960 [details]
build.log

build.log for x86_64

Comment 6 FTBFS 2010-02-13 18:08:52 UTC
Created attachment 393961 [details]
mock.log

mock.log for x86_64

Comment 7 Bug Zapper 2010-03-15 14:59:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Charley Wang 2010-05-12 15:14:46 UTC
Created attachment 413456 [details]
Fix for notecase FTBFS

Hi,

I've attached a quick fix for the FTBFS bug for your package. The package successfully rebuilds for me with this change.

I can commit the change directly if there are no objections.

-Charley

Comment 9 Martin-Gomez Pablo 2010-05-12 22:09:51 UTC
I have some free time towmorrow to take care of this. Thanks you for the patch, I didn't take the time to dive into.

Comment 10 Fedora Update System 2010-05-14 16:48:58 UTC
notecase-1.6.1-9.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/notecase-1.6.1-9.fc13

Comment 11 Fedora Update System 2010-05-15 20:32:18 UTC
notecase-1.6.1-9.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update notecase'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/notecase-1.6.1-9.fc13

Comment 12 Fedora Update System 2010-08-20 01:30:46 UTC
notecase-1.6.1-9.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.