Bug 565181 - FTBFS nas-1.9.1-6.fc12: ImplicitDSOLinking
FTBFS nas-1.9.1-6.fc12: ImplicitDSOLinking
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nas (Show other bugs)
13
All Linux
high Severity high
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On: 571653
Blocks: 564245 583278
  Show dependency treegraph
 
Reported: 2010-02-13 13:10 EST by FTBFS
Modified: 2010-08-23 21:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: nas-1.9.2-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-21 00:27:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (101.60 KB, text/plain)
2010-02-13 13:10 EST, FTBFS
no flags Details
build.log (344.03 KB, text/plain)
2010-02-13 13:10 EST, FTBFS
no flags Details
mock.log (935 bytes, text/plain)
2010-02-13 13:10 EST, FTBFS
no flags Details
root.log (169.02 KB, text/plain)
2010-02-13 13:10 EST, FTBFS
no flags Details
build.log (343.00 KB, text/plain)
2010-02-13 13:10 EST, FTBFS
no flags Details
mock.log (943 bytes, text/plain)
2010-02-13 13:10 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 13:10:04 EST
nas-1.9.1-6.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 13:10:07 EST
Created attachment 393998 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 13:10:09 EST
Created attachment 393999 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 13:10:10 EST
Created attachment 394000 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 13:10:11 EST
Created attachment 394001 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 13:10:13 EST
Created attachment 394002 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 13:10:14 EST
Created attachment 394003 [details]
mock.log

mock.log for x86_64
Comment 7 Fedora Update System 2010-03-14 14:50:47 EDT
nas-1.9.1-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/nas-1.9.1-7.fc12
Comment 8 Bug Zapper 2010-03-15 10:59:32 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2010-03-15 20:36:15 EDT
nas-1.9.1-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nas-1.9.1-7.fc12
Comment 10 Bruno Wolff III 2010-03-27 17:09:32 EDT
The fix tested in f12 didn't fix everything as the f13 builds are failing due to -lXau missing.
Comment 11 Bruno Wolff III 2010-03-28 10:10:00 EDT
I have been trying to figure this one out as part of my Fedora Engineering Services task and have got a clue that I'll mention since I might not get back to it again for a week.
make World works without a lot of fuss. But the make install step with alternate destinations seems to trigger rebuilding of a few things. Notably auctl, which fails. I am not used to using Imakefiles and I havn't been able to figure out why this happens yet. But I suspect that this is related to the failure to build issue.
Comment 12 Fedora Admin XMLRPC Client 2010-08-04 13:32:39 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Fedora Update System 2010-08-11 04:35:10 EDT
nas-1.9.2-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/nas-1.9.2-1.fc14
Comment 14 Fedora Update System 2010-08-11 04:35:25 EDT
nas-1.9.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/nas-1.9.2-1.fc13
Comment 15 Fedora Update System 2010-08-11 04:54:51 EDT
nas-1.9.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/nas-1.9.2-1.fc12
Comment 16 Fedora Update System 2010-08-12 00:06:54 EDT
nas-1.9.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nas-1.9.2-1.fc12
Comment 17 Fedora Update System 2010-08-12 00:11:51 EDT
nas-1.9.2-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nas-1.9.2-1.fc13
Comment 18 Fedora Update System 2010-08-12 15:59:17 EDT
nas-1.9.2-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nas-1.9.2-1.fc14
Comment 19 Fedora Update System 2010-08-21 00:27:29 EDT
nas-1.9.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2010-08-21 00:29:56 EDT
nas-1.9.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2010-08-23 21:42:06 EDT
nas-1.9.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.