Bug 565191 - FTBFS ed2k_hash-0.4.0-9.fc12: ImplicitDSOLinking
FTBFS ed2k_hash-0.4.0-9.fc12: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ed2k_hash (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 13:11 EST by FTBFS
Modified: 2010-02-14 19:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-14 19:19:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (348.32 KB, text/plain)
2010-02-13 13:12 EST, FTBFS
no flags Details
build.log (12.58 KB, text/plain)
2010-02-13 13:12 EST, FTBFS
no flags Details
mock.log (958 bytes, text/plain)
2010-02-13 13:12 EST, FTBFS
no flags Details
root.log (516.51 KB, text/plain)
2010-02-13 13:12 EST, FTBFS
no flags Details
build.log (11.97 KB, text/plain)
2010-02-13 13:12 EST, FTBFS
no flags Details
mock.log (967 bytes, text/plain)
2010-02-13 13:12 EST, FTBFS
no flags Details

  None (edit)
Description FTBFS 2010-02-13 13:11:58 EST
ed2k_hash-0.4.0-9.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 13:12:02 EST
Created attachment 394055 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 13:12:03 EST
Created attachment 394056 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 13:12:04 EST
Created attachment 394057 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 13:12:06 EST
Created attachment 394058 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 13:12:07 EST
Created attachment 394059 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 13:12:08 EST
Created attachment 394060 [details]
mock.log

mock.log for x86_64
Comment 7 Dominik 'Rathann' Mierzejewski 2010-02-14 14:06:29 EST
Cannot reproduce, builds fine in mock for me.
Comment 8 FTBFS 2010-02-14 16:45:03 EST
It has failed twice on two architectures for me.  This is the reported failure:

/usr/bin/ld: ed2k_hash_gui-Semaphore.o: undefined reference to symbol 'sem_post@@GLIBC_2.1'
/usr/bin/ld: note: 'sem_post@@GLIBC_2.1' is defined in DSO /lib/libpthread.so.0 so try adding it to the linker command line
/lib/libpthread.so.0: could not read symbols: Invalid operation

And it failed a scratch build in koji for the same reason:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1986397

Please review.
Comment 9 Dominik 'Rathann' Mierzejewski 2010-02-14 19:19:50 EST
Yeah, I missed the "add this special repository" part. Should be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.