Bug 565197 - FTBFS bluefish-2.0.0-0.3.rc3.fc13: ImplicitDSOLinking
FTBFS bluefish-2.0.0-0.3.rc3.fc13: ImplicitDSOLinking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluefish (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
: Triaged
Depends On:
Blocks: 564245
  Show dependency treegraph
 
Reported: 2010-02-13 13:13 EST by FTBFS
Modified: 2010-02-15 09:39 EST (History)
1 user (show)

See Also:
Fixed In Version: bluefish-2.0.0-0.4.rc3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-15 09:39:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (812.98 KB, text/plain)
2010-02-13 13:13 EST, FTBFS
no flags Details
build.log (106.27 KB, text/plain)
2010-02-13 13:13 EST, FTBFS
no flags Details
mock.log (1.03 KB, text/plain)
2010-02-13 13:13 EST, FTBFS
no flags Details
root.log (1.18 MB, text/plain)
2010-02-13 13:13 EST, FTBFS
no flags Details
build.log (102.45 KB, text/plain)
2010-02-13 13:13 EST, FTBFS
no flags Details
mock.log (1.03 KB, text/plain)
2010-02-13 13:13 EST, FTBFS
no flags Details
Patch to check for log10 in -lm (1.99 KB, patch)
2010-02-15 05:48 EST, Paul Howarth
no flags Details | Diff

  None (edit)
Description FTBFS 2010-02-13 13:13:04 EST
bluefish-2.0.0-0.3.rc3.fc13.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
This failure is due to a change in the linker default behavior, which uncovered a fault in your package.  See http://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking .
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2010-02-13 13:13:09 EST
Created attachment 394091 [details]
root.log

root.log for i386
Comment 2 FTBFS 2010-02-13 13:13:10 EST
Created attachment 394092 [details]
build.log

build.log for i386
Comment 3 FTBFS 2010-02-13 13:13:11 EST
Created attachment 394093 [details]
mock.log

mock.log for i386
Comment 4 FTBFS 2010-02-13 13:13:14 EST
Created attachment 394094 [details]
root.log

root.log for x86_64
Comment 5 FTBFS 2010-02-13 13:13:15 EST
Created attachment 394095 [details]
build.log

build.log for x86_64
Comment 6 FTBFS 2010-02-13 13:13:17 EST
Created attachment 394096 [details]
mock.log

mock.log for x86_64
Comment 7 Paul Howarth 2010-02-15 05:48:06 EST
Created attachment 394284 [details]
Patch to check for log10 in -lm

The problem was due to the use of the log10 function in bftextview2.c without linking against -lm.

The attached patch checks if -lm is needed for log10 and resolves the build failure. However, it does result in everything being linked against -lm, which is a bit unnecessary. Hopefully someone better versed in autotools can fix this with something a little more targeted.

Note You need to log in before you can comment on or make changes to this bug.