Bug 56520 - Appears to be related to Quota. Similar to 56338???????
Appears to be related to Quota. Similar to 56338???????
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 10:42 EST by Aaron Freed
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 16:36:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Syslog output (/var/log/messages) (or possibly Kernel Oops) (124.57 KB, text/plain)
2001-11-20 10:43 EST, Aaron Freed
no flags Details

  None (edit)
Description Aaron Freed 2001-11-20 10:42:25 EST
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:
Assumed that reenabling Quota on RedHat 7.2 will cause the bug to recurr
after a while.  (Could not experiment--this is a production server!!!)

Steps to Reproduce:
1.  SU to root and then turn on quotas with "quotaon" 
2.  Transfer large amounts of data to disk with quotas (e.g. a file of 5 GB
in size.)
3.  Bug should recurr.

Actual Results:
System locks up with attached Kernel bug reported.

Expected Results:
It is expected that Quota work properly with EXT3 filesystem, regardless of
whether RedHat 7.2 is installed "clean" or is upgraded to from an earlier
version.  Also expected that relevant man pages would mention EXT3
(especially if Quota is NOT compatible with it.)

Additional Information:
1.  Machine originally had RedHat 7.1 installed.  Quotas were enabled on
the 100 GB drive (usr2), but not on the 30 GB drive (everything else). 
2.  An upgrade to RedHat 7.2 was performed.  
3.  Quota databases were NOT rebuilt with Quotacheck or any other tool (To
be honest, I forgot that Quotas were on when I upgraded.)
4.  The system failed after approximately one day with the attached
failure. (Entire /var/log/messages is attached.  Failure shows bug
beginning at line 1304.)
5.  Extensive repairs had to be made to /usr2 using fsck utility.
6.  System was rebooted and "quotaoff" executed at the command line.  
7.  No further failures occurred.

Configuration:  
Machine is an IBM NetVista with single PIII 933 and two physical drives.
/dev/hda is 30 GB drive with no quotas.  /dev/hdb is 100 GB drive that HAD
quotas turned on, but I have since turned them off.  Machine has 384 MB RAM
and one CD-RW.

Additional information in attached "Messages.2" file.  Bug(s) appear at
1304.

There is another bug report for Quota at 56338, but I felt mine was
sufficiently dissimilar that it was worth a second report (It might even be
a kernel bug, not Quota at all!)
Comment 1 Aaron Freed 2001-11-20 10:43:55 EST
Created attachment 38025 [details]
Syslog output (/var/log/messages) (or possibly Kernel Oops)
Comment 2 Phil Copeland 2002-08-06 16:47:47 EDT
Wow,.. really old bug.
please upgrade to latest 7.2 errata kernel and install the rawhide quota package
(quota-3.06-2 or -3 if it gets uploaded tonight)

That should fix this problem

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.