Bug 56522 - kdeadmin lilo-config core dump when probe button selected
kdeadmin lilo-config core dump when probe button selected
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdeadmin (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 10:56 EST by Salina Chu
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-20 10:56:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Salina Chu 2001-11-20 10:56:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Select KDE control center
On left side of window, select System
Select Boot Manager ( LILO )
when window for lilo comes up, select tab that says Operating Systems
On the Operating Systems menu, select probe button
We get kde crash that shows we are getting sigsegv

The reason is in
     kdeadmin-2.2/lilo-config/kde-qt-common/images.cpp

in saveChanges, l is 0
---------------------------------------------------------
void Images::saveChanges() // SLOT
{
        if(!current.isEmpty()) {
                liloimage *l=lilo->images[current.latin1()];
                l->set("image", image->text().latin1(), true, true);
                l->set("label", label->text().latin1(), true, true, "\t");
                l->set("root", root->text().latin1(), true, true, "\t");
                l->set("initrd", initrd->text().latin1(), true, 
true, "\t");
                l->set("append", append->text().latin1(), true, 
true, "\t");
        }                             
----------------------------------------------------------------

If we add testing l is non-zero before all the l->set
this will fix the core dump problem 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.select kde control center icon
2.select System
3.select Boot Manager ( LILO )
4.select Operating System tab 
5.select probe button
	

Actual Results:  get kde crash window

Expected Results:  see different kernels listed in /etc/lilo.conf

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-11-22 06:13:48 EST
Thanks, I've fixed it in the KDE CVS tree, it'll be in the next release.


Note You need to log in before you can comment on or make changes to this bug.