Bug 565231 - libvirtError: operation failed: could not query memory balloon allocation
libvirtError: operation failed: could not query memory balloon allocation
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-13 16:56 EST by John L Magee
Modified: 2010-11-17 14:23 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-17 14:23:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
misc logs and file contents (2.72 KB, text/plain)
2010-02-13 16:56 EST, John L Magee
no flags Details

  None (edit)
Description John L Magee 2010-02-13 16:56:42 EST
Created attachment 394163 [details]
misc logs and file contents

Description of problem:
libvirtError: operation failed: could not query memory balloon allocation
when clicking stop button in Virt-manager

Version-Release number of selected component (if applicable):
0.7.1-15.fc12 

How reproducible: every time


Steps to Reproduce:
1.start Windows XP Virtual Machine
2.click Stop button for that VM in Virt Manager
3.
  
Actual results:error noted above


Expected results:gracefully power off VM


Additional info: same VMs worked OK with Fedora 11
Comment 1 Carlos Maiolino 2010-03-14 17:08:48 EDT
Hi,

I have having the same problem with a x86 Hypervisor and x86 guest.

Versions:

F12 - fully updated
qemu-kvm-0.11.0-13.fc12.i686
kernel-PAE-2.6.32.9-70.fc12.i686


Is possible to boot my virtual machine, just using qemu. But, using qemu-kvm the virtual machine don't start properly with the following dump:

[root@orion ~]# qemu-kvm -boot c -drive file=/dev/VMS/F12_node1
unhandled vm exit: 0x11
rax 000000000000f000 rbx 000000000000fff6 rcx 0000000000000000 rdx 0000000000000623
rsi 0000000000000000 rdi 0000000000000500 rsp 000000000000ffd0 rbp 000000000000ffd2
r8  0000000000000000 r9  0000000000000000 r10 0000000000000000 r11 0000000000000000
r12 0000000000000000 r13 0000000000000000 r14 0000000000000000 r15 0000000000000000
rip 00000000000005f8 rflags 00010093
cs f000 (000f0000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
ds 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
es 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
ss 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
fs 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
gs 0000 (00000000/0000ffff p 1 dpl 3 db 0 s 1 type 3 l 0 g 0 avl 0)
tr 0000 (fffbd000/00002088 p 1 dpl 0 db 0 s 0 type b l 0 g 0 avl 0)
ldt 0000 (00000000/0000ffff p 1 dpl 0 db 0 s 0 type 2 l 0 g 0 avl 0)
gdt 0/ffff
idt 0/ffff
cr0 10 cr2 0 cr3 0 cr4 0 cr8 0 efer 0
Aborted (core dumped)

I got a corefile, so, if it is necessary, how can I send it ? Once it has 161MB.

If more information is needed, please ask me
Comment 2 K Anderson 2010-03-31 18:58:47 EDT
Just reporting that I am having the same issue as Carlos post-update (VM worked prior to yum update).  I can not start my KVM VMs unless I run them using just QEMU. 

In the virt-manager I get...

Error starting domain: operation failed: could not query memory balloon allocation

Details:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 588, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 151, in startup
    self._update_status()
  File "/usr/share/virt-manager/virtManager/domain.py", line 806, in _update_status
    info = self.get_info()
  File "/usr/share/virt-manager/virtManager/domain.py", line 139, in get_info
    return self._backend.info()
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 530, in info
    if ret is None: raise libvirtError ('virDomainGetInfo() failed', dom=self)
libvirtError: operation failed: could not query memory balloon allocation


System: Fedora 12
Kernel: 2.6.32.10-90.fc12.i686.PAE
QEMU-KVM: 0.11.0-13.fc12.i686
Available RAM: 4.5Gb/6Gb
VM allocation: 512mb


Please feel free to contact me if you need more information or need anything tested :)
Comment 3 Bug Zapper 2010-11-03 18:09:56 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Cole Robinson 2010-11-17 14:23:30 EST
Hmm, this bug has been dormant for a while. Closing for now, if someone can reproduce with F13 or later, please reopen. Thanks

Note You need to log in before you can comment on or make changes to this bug.