Bug 56528 - gettext.m4: Check for bison version doesn't work with current bison
Summary: gettext.m4: Check for bison version doesn't work with current bison
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gettext   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-20 16:57 UTC by Bernhard Rosenkraenzer
Modified: 2007-03-27 03:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-20 16:57:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernhard Rosenkraenzer 2001-11-20 16:57:21 UTC
Description of Problem:
Any configure script using AM_WITH_NLS (provided by 
/usr/share/aclocal/gettext.m4, provided by gettext) fails to recognize 
bison 1.3x as a good version (apparently, the layout of bison --version 
has changed).

Version-Release number of selected component (if applicable):
gettext-0.10.40-2
bison-1.30-2

How Reproducible:
100%

Steps to Reproduce:
1. Try rebuilding e.g. psmisc

Actual Results:
checking for bison... bison
checking version of bison... v. ?.??, bad


Expected Results:
checking for bison... bison
checking version of bison... v. 1.30, ok



Additional Information:
Setting priority==high because AM_WITH_NLS is used by a lot of 
applications, and failing the test will cause quite a few packages to add 
unnecessary workarounds to their code, producing bad binary RPMs.

Comment 1 Trond Eivind Glomsrxd 2001-11-20 20:34:33 UTC
Not a gettext bug, but a bug in the distributed files in psmisc. "aclocal ;
autoconf" will copy in the files from the local system and fix the problem.

Comment 2 Bernhard Rosenkraenzer 2001-11-20 20:44:57 UTC
Argh, right, I hadn't updated gettext on the build machine yet. (0.10.38-7 had 
this behavior).



Note You need to log in before you can comment on or make changes to this bug.