Bug 565306 - AttributeError: Users instance has no attribute 'createLuserConf'
Summary: AttributeError: Users instance has no attribute 'createLuserConf'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:080ba03d90b9b6a5d...
: 565536 566012 566341 566788 (view as bug list)
Depends On:
Blocks: F13Alpha, F13AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-02-14 16:19 UTC by Jesse Keating
Modified: 2013-01-10 03:32 UTC (History)
9 users (show)

Fixed In Version: anaconda-13.27-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-23 23:43:56 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (258.15 KB, text/plain)
2010-02-14 16:19 UTC, Jesse Keating
no flags Details

Description Jesse Keating 2010-02-14 16:19:13 UTC
The following was filed automatically by anaconda:
anaconda 13.26 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/users.py", line 272, in write
    self.createLuserConf(instPath, algoname=self.getPassAlgo())
  File "/usr/bin/anaconda", line 657, in write
    self.users.write(self.rootPath)
  File "/usr/lib/anaconda/backend.py", line 314, in writeConfiguration
    anaconda.write()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 657, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1184, in <module>
    anaconda.intf.run(anaconda)
AttributeError: Users instance has no attribute 'createLuserConf'

Comment 1 Jesse Keating 2010-02-14 16:19:17 UTC
Created attachment 394207 [details]
Attached traceback automatically from anaconda.

Comment 2 Hans de Goede 2010-02-15 10:11:22 UTC
This is fallout from the instData removal, assigning to Chris.

Comment 3 Chris Lumens 2010-02-15 15:46:23 UTC
*** Bug 565536 has been marked as a duplicate of this bug. ***

Comment 4 James Laska 2010-02-15 17:27:25 UTC
This seems to be a common bug for the Alpha test compose, I created an updates image to work around this problem.

http://jlaska.fedorapeople.org/updates-565306.img

Comment 5 Chris Lumens 2010-02-16 21:59:05 UTC
*** Bug 566012 has been marked as a duplicate of this bug. ***

Comment 6 Chris Lumens 2010-02-18 03:35:11 UTC
*** Bug 566341 has been marked as a duplicate of this bug. ***

Comment 7 Chris Lumens 2010-02-19 18:10:08 UTC
*** Bug 566788 has been marked as a duplicate of this bug. ***

Comment 8 James Laska 2010-02-19 18:45:59 UTC
Confirmed fix using updates.img posted in comment#4.  I'll hold off on closing this issue until anaconda-13.27 (or newer) is available for test.

Comment 9 James Laska 2010-02-23 23:43:56 UTC
Fix confirmed using anaconda-13.29 (F-13-Alpha-RC2)


Note You need to log in before you can comment on or make changes to this bug.