Bug 56533 - GRUB hangs after stage1 load on Gateway E-3400
GRUB hangs after stage1 load on Gateway E-3400
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 12:49 EST by Steve Bonneville
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-02 15:08:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Bonneville 2001-11-20 12:49:33 EST
Description of Problem:

After installing and selecting GRUB as the bootloader on a Gateway E-3400
workstation and booting, first stage appears to load okay from the MBR,
second stage hangs with the floppy drive light lit.  Don't get to the GRUB
splashscreen.  HD and boot MBR is /dev/hda, floppy on /dev/fd0, CDROM on
/dev/hdc.  LILO seems to work fine.

One apparently identical machine, except configured with its only hard
drive on /dev/hdb, and no /dev/hda, booted.

BIOS is an AMIBIOS 7.00.xx, BIOS version is 01.00.P06 08/17/00.  

These machines are off-site; I should have access to them again the week
after Thanksgiving.
Comment 1 Jeremy Katz 2001-11-28 20:54:36 EST
Does lilo work fine if you have the lba32 keyword in the lilo.conf?
Comment 2 Steve Bonneville 2001-12-10 09:53:41 EST
I did some more thorough testing and came up with the following results.

If the hard drive is the master (/dev/hda) and there is nothing as the slave,
LILO boots fine with either "linear" or "lba32".  GRUB stops at "Loading
stage2..." with the floppy drive light solidly lit.

If the hard drive is the slave (/dev/hdb) and there is nothing as the master,
GRUB boots fine.  LILO stops at "L" with the floppy drive light solidly lit,
using either "linear" or "lba32".  GRUB correctly mapped /dev/hdb to (hd0) in
this circumstance.

So, it turns out this problem affects both GRUB and LILO.

Hard drive was a Quantum Fireball LM20.5, using cable detection to determine
whether it's a master or a slave.  Floppy drive had no disk inserted.
Comment 3 Jeremy Katz 2001-12-15 02:05:30 EST
The usual fun question is do you have the most current BIOS for the machines
installed?
Comment 4 Steve Bonneville 2001-12-17 11:14:59 EST
Heh.  According to the owners, yes.  There's several possible BIOS types on
E-3400 machines according to the Gateway site, but it looks to *me* that there
might be a P07 revision they missed from 9/2001.

Google also found another report of this bug with GRUB on an E-3400 in November
2000, in the bug-grub archive:

  http://mail.gnu.org/pipermail/bug-grub/2000-November/004030.html

This user claimed disabling the floppy controller in the BIOS allowed GRUB to
boot normally.  There was no follow-up, but maybe he knows something more.
Comment 5 Jeremy Katz 2002-01-02 15:08:43 EST
ould you try the test package at http://people.redhat.com/~katzj/grub/.  If you
install the package and then run `/sbin/grub-install /dev/hda` (or wherever you
have grub installed other than /dev/hda) and let me know if that works any better?
Comment 6 Jeremy Katz 2002-01-21 20:30:58 EST
Others claim that this works much better on similar hardware
Comment 7 Daniel Senie 2002-04-14 00:55:45 EDT
Same issue on Intel ISP1100 server iron, which is a 440BX chipset machine. 
Disabling the floppy drive in the BIOS permitted booting.

Would be nice to see an errata fixing this for RH7.2, rather than Rawhide. On 
servers, updating to the latest RedHat is deadly. Waiting until a release has 
been out 6 months is much safer, but we REALLY rely on RedHat supporting the 
releases in the field. This means marking things fixed in Rawhide is suspect.

Note You need to log in before you can comment on or make changes to this bug.