Bug 565343 - Rotate Cube keyboard bindings don't work.
Rotate Cube keyboard bindings don't work.
Status: CLOSED DUPLICATE of bug 532229
Product: Fedora
Classification: Fedora
Component: ccsm (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Izhar Firdaus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-14 18:01 EST by Maciej Żenczykowski
Modified: 2010-03-08 08:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-04 14:27:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Maciej Żenczykowski 2010-02-14 18:01:38 EST
I haven't been able to quite figure this one out, but:

- I have an x86_64 Fedora 12 desktop with Compiz enabled, with desktop cube with rotation (intel driver).

- If I go into System > Preferences > CompizConfig Settings Manager I can configure many aspects of compiz.

I have "Enable Rotate Cube" turned on, and on the Bindings tab I have 'initiate' as "<super>Button 1" - this works, windows key + primary mouse button allow me to rotate/drag the desktop cube around.

However, on the same pane there are settings for keyboard rotation:
- Rotate: Left/Right/Left with Window/Right with Window,
  I have these set to <super>Left <super>Right <shift><super>Left <shift><super>Right

*BUT* everything reacts to <left ctrl><left alt>Left instead of <super>Left (etc for the other 3 actions)

I managed to somehow get this working (lots of random clicking in the configuration panel, turning plugins on and off, changing keybinding here and there, etc), but after logout/login, I'm back to seeing <left ctrl><left alt> even though the Rotate Cube Bindings are explicitly showing <super>.
Comment 1 gregor 2010-03-04 12:22:21 EST
hi,

i have the same problem that no keybinding changes works with ccsm
any news here?
kernel: 2.6.31.12-174.2.22.fc12.x86_64
ccsm: ccsm-0.8.2-3.fc12.noarch

greetings
gregor
Comment 2 leigh scott 2010-03-04 14:27:32 EST
https://fedoraproject.org/wiki/Common_F12_bugs#Changes_in_CCSM_do_not_affect_Compiz

*** This bug has been marked as a duplicate of bug 532229 ***
Comment 3 gregor 2010-03-08 08:15:49 EST
thx worked for me.

Note You need to log in before you can comment on or make changes to this bug.