Bug 56535 - Flag '--force' does not work as advertised
Flag '--force' does not work as advertised
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 13:21 EST by Michal Jaegermann
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-20 13:21:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-11-20 13:21:35 EST
Description of Problem:

Typing 'rpm --help' one can see this:

--force[|=0x74]            short hand for --replacepkgs --replacefiles

This indeed used to be true.  Currently if one tries to "force"
a re-installation of an existing package (for whatever reasons - say
that some files got corrupted) this will be rejected.  Luckily
'--replacepkgs --replacefiles' still works (and which means that
the help text is misleading).

'--force' is actually a short hand for the two above plus '--oldpackage'
and the later check apparently become a bit too aggresive.
Comment 1 Jeff Johnson 2001-12-02 06:23:07 EST
The fix for this -- if I'm permitted -- is gonna be to remove the --force
option entirely, there's more to package management than Applying The
Big Hammer.

Since I will never be permitted to remove --force, I choose to leave
bad enough alone.
Comment 2 Michal Jaegermann 2001-12-02 11:32:17 EST
I can understand that you are fed up with whines from folks which used
The Big Hammer to hit their thumbs but there are situations when uninstalling
and reinstalling packages, instead of using '--force', is not a feasible
option.  As the old principle goes "if you will ban stupid things you will
prevent smart things as well" and attempts to make things "idiot-proof"
either dismally fail or cripple them beyond usability.

Note You need to log in before you can comment on or make changes to this bug.