Bug 56536 - Floating point exception bombs
Summary: Floating point exception bombs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xsane   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-20 18:26 UTC by Michal Jaegermann
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-08 16:05:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-11-20 18:26:27 UTC
Description of Problem:

Choosing a jpeg format output in xsane menu causes an immediate
program termination with a "Floating point exception".

How Reproducible:

Absolute reliability. :-)

Comment 1 Michal Jaegermann 2001-11-20 21:16:03 UTC
Sigh!  Yesterday it was bombing out always and today I cannot reproduce
that anymore; neither with a debugging version nor with original executables.
But the difference is that today I have recompiled sane-backends due to
a bug #56540.

Comment 2 Tim Waugh 2001-11-20 23:03:18 UTC
The 0.81 changelog mentions floating point exceptions.  I wonder if that fixes 
it.


Comment 3 Tim Waugh 2001-11-30 13:49:13 UTC
Is it previews that this happens with?

Comment 4 Michal Jaegermann 2001-11-30 14:42:51 UTC
Both!  That means that if jpeg format was chosen then attempts to get
anything out of a scanner caused an immediate floating point exception
and exit from xsane.  But by the time I atttempted to debug that it
mysteriously vanished.

On the top of that I do not an access to that scanner anymore as it went
to its real owner.

Comment 5 Tim Waugh 2002-01-08 16:05:51 UTC
I'm going to mark this as closed, since I can't reproduce it here and both 
xsane and sane have had floating point problems fixed recently.



Note You need to log in before you can comment on or make changes to this bug.