Bug 565410 - Kontact running but not showing up.
Kontact running but not showing up.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-4.4
  Show dependency treegraph
 
Reported: 2010-02-15 04:01 EST by Thomas Janssen
Modified: 2010-02-27 21:16 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-27 21:16:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 227636 None None None Never

  None (edit)
Description Thomas Janssen 2010-02-15 04:01:21 EST
Description of problem:
If you start Kontact (nepomuk running very well) it starts, but no GUI comes up. You can see that it's working behind the scenes if you follow the output in a terminal. Kmail fetching emails for example.

You can make the GUI appear with: 
qdbus org.kde.kontact /kontact/MainWindow_1 com.trolltech.Qt.QWidget.show

But it's busy, no reaction at all. Another funny thing is two green arrows in the upper left corner (one single and a double) on top of the GUI of Kontact.

Version-Release number of selected component (if applicable):
kdepim-runtime-debuginfo-4.4.0-2.fc12.x86_64
kdepimlibs-4.4.0-2.fc12.x86_64
kdepim-runtime-4.4.0-2.fc12.x86_64
kdepim-debuginfo-4.4.0-4.fc12.x86_64
kdepimlibs-akonadi-4.4.0-2.fc12.x86_64
kdepim-libs-4.4.0-4.fc12.x86_64
kdepim-runtime-libs-4.4.0-2.fc12.x86_64
kdepimlibs-devel-4.4.0-2.fc12.x86_64
kdepimlibs-debuginfo-4.4.0-2.fc12.x86_64


How reproducible:
Everytime you try to start Kontact

Steps to Reproduce:
1. start Kontact
2. run: qdbus org.kde.kontact /kontact/MainWindow_1 com.trolltech.Qt.QWidget.show
3. Wait a few hours and kill kontact then, because nothing happens.
  
Actual results:
Kontact not proper starting

Expected results:
Kontact starts proper

Additional info:
Started Kontact within gnome shows me that it starts nepomuk perfectly (notification from nepomuk in systray saying akonadi server is started and can be used), but kontact though hangs in a death loop telling in a popup "Starting akonadi server..".
Comment 1 Steven M. Parrish 2010-02-18 19:24:56 EST
Thank you for taking the time to report this issue to us.  This is an issue which is best addressed by the upstream developers.

Please file a report at bugs.kde.org , and when done add the upstream report info to this report.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Thomas Janssen 2010-02-19 03:21:28 EST
https://bugs.kde.org/show_bug.cgi?id=227636
Comment 3 Thomas Janssen 2010-02-24 14:49:21 EST
To complete it here. The apps like kmail for example do start fine stand-alone.
Comment 4 Fedora Update System 2010-02-26 13:34:09 EST
openswan-2.6.24-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openswan-2.6.24-3.fc13
Comment 5 Kevin Kofler 2010-02-27 21:16:01 EST
(Please disregard that openswan update notice, it was due to a typo in the original Bodhi submission for that update.)

Thank you for taking the time to report this issue to us. As we decided this issue is not a blocker for our 4.4 update and as this bug is already reported upstream, we are going to close it as UPSTREAM.

We will continue to track the issue in the centralized upstream bug tracker,
and will review any bug fixes that become available for consideration in future
updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.