Bug 56557 - [nvidia, sblive] noise with 2.4.9-13smp emu10k card prev. kernels were OK
Summary: [nvidia, sblive] noise with 2.4.9-13smp emu10k card prev. kernels were OK
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-20 22:52 UTC by stuart boreen
Modified: 2007-04-18 16:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 22:33:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (11.90 KB, text/plain)
2001-11-20 22:56 UTC, stuart boreen
no flags Details
result of /sbin/lsmod (1020 bytes, text/plain)
2001-11-20 22:57 UTC, stuart boreen
no flags Details

Description stuart boreen 2001-11-20 22:52:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2

Description of problem:
Dual athlon on Thunder K7 - used up2date to get new 2.4.9-13smp kernel and
now have problems with game sounds. Xmms plays OK, realplayer OK, Kmidi is
OK but Lbreakou2 and Rocks and diamonds make terrible noise *most of the
time* They work fine in 2.4.9-7smp

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Fresh 7.2 install
2.use up2date to install 2.4.9-13smp
3.play rocksndiamonds or lbreakout2 and get noise. Also noise at closing
Descent -3 Loki demo
	

Actual Results:  Got noise

Expected Results:  Pleasant sounds

Additional info:

RH 7.2 on SCSI Thunder K7 with emu10k based card (?SB live value)
Nvidia accel driver loaded for accel x (custom made by make from .tar.gz
files from Nvidia) 
Strange that xmms and Kmidi and realplayer all play fine...
Again, earlier kernel 2.4.9-7smp worked fine -- it was the kernel I got
from up2date that caused the bug.
Did I get an Athlon optimized kernel? Or does up2date just get a default
i686 kernel?

Comment 1 stuart boreen 2001-11-20 22:56:11 UTC
Created attachment 38143 [details]
dmesg

Comment 2 stuart boreen 2001-11-20 22:57:21 UTC
Created attachment 38144 [details]
result of /sbin/lsmod

Comment 3 Arjan van de Ven 2001-11-21 16:01:57 UTC
up2date might default to the i686 kernel; 
there was no change in emu10k between any 7.2 kernel unfortionatly.....

Comment 4 stuart boreen 2001-11-21 19:27:13 UTC
2 more thoughts:

up2date should be able to figure out If I need an Athlon kernel  or an i586 etc.
Could some other component be causing trouble? The SDL libraries? I don't fully
understand how different sounds are handled/generated

Comment 5 Philip Long 2001-11-27 17:41:59 UTC
Seems to be the same bug as 55493, and possibly 53803 and 55281.  I'll post my
comments to 55493 as that seems to be the best discussion so far.

Comment 6 Alan Cox 2003-06-07 22:33:30 UTC
Should be resolved with current errata kernels. If not please re-open


Note You need to log in before you can comment on or make changes to this bug.