Bug 56561 - gnome-terminal -e command; #runs a shell not the command
gnome-terminal -e command; #runs a shell not the command
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 19:33 EST by John M O'Donnell
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-26 19:05:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John M O'Donnell 2001-11-20 19:33:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
gnome-terminal -e command
or
gnome-terminal -x command

should run the command in a new terminal.  Worked great in RH 7.1.
Doesn't work in RH 7.2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.gnome-terminal -e mutt
2.
3.
	

Actual Results:  gnome-terminal with shell prompt

Expected Results:  gnome-terminal with mutt running

Additional info:

applies to -e and -x options.  Also does not depend
on the program selected - pine, ls, csh...
Comment 1 Need Real Name 2001-11-21 09:53:02 EST
I could not reproduce this problem.

False alarm :).

Comment 2 John M O'Donnell 2001-11-26 19:05:48 EST
.gnome/gnome-terminal contained a [factory] section, which is nolonger
supported - also a [dummy]section.  It also contained the new entries for
factory stuff.  With that in there it neith complains nor works...
so not it's out and it works.

Note You need to log in before you can comment on or make changes to this bug.