Bug 565693 - Install boot hangs for a long time probing floppy drive
Summary: Install boot hangs for a long time probing floppy drive
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 574492 586037 (view as bug list)
Depends On:
Blocks: 494832 585927
TreeView+ depends on / blocked
 
Reported: 2010-02-15 23:09 UTC by Orion Poplawski
Modified: 2011-04-24 13:42 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 585927 (view as bug list)
Environment:
Last Closed: 2011-04-24 13:42:14 UTC
Type: ---


Attachments (Terms of Use)

Description Orion Poplawski 2010-02-15 23:09:58 UTC
Description of problem:

PXE/ks install on old Dell laptop.  Install hangs for quite a while probing for a non-existent floppy drive.

Version-Release number of selected component (if applicable):
13.26

syslog contains messages like:

15:54:39,095 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:55:17,226 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:55:17,226 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:55:55,361 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:55:55,364 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:56:33,492 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:56:33,494 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:56:59,697 ERR udevd: worker [374] unexpectedly returned with status 0x0100
15:56:59,700 ERR udevd: worker [374] failed while handling '/devices/platform/floppy.0/block/fd0'

Comment 1 Hans de Goede 2010-02-16 08:10:40 UTC
The problem is the kernel thinks you have a floppy drive, while you don't. This is usually caused by the BIOS reporting a floppy drive is present. Go to the BIOS and see if you can configure what kind of floppy driver the system has there and set it to None.

Please let us know if this resolves this issue.

Comment 2 Orion Poplawski 2010-02-16 15:32:09 UTC
BIOS has diskettes disabled.  It has a modular bay that can accept optical, floppy, or battery though.  Currently has optical in it, but perhaps the BIOS always lists floppy as a possiblity.  I don't remember this being an issue with F12, but I see similar messages from that install too:

anaconda.syslog:<6>Floppy drive(s): fd0 is 1.44M
anaconda.syslog:<3>end_request: I/O error, dev fd0, sector 0
anaconda.syslog:<3>end_request: I/O error, dev fd0, sector 0
anaconda.syslog:<3>Buffer I/O error on device fd0, logical block 0
anaconda.syslog:<3>end_request: I/O error, dev fd0, sector 0
anaconda.syslog:<3>Buffer I/O error on device fd0, logical block 0

Not as many though so maybe it didn't take as long.

Full fd messages from current:

15:54:39,095 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:55:17,226 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:55:17,226 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:55:55,361 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:55:55,364 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:56:33,492 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:56:33,494 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:56:59,697 ERR udevd: worker [374] unexpectedly returned with status 0x0100
15:56:59,700 ERR udevd: worker [374] failed while handling '/devices/platform/floppy.0/block/fd0'
15:57:11,622 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:57:11,624 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:57:49,756 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:57:49,758 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:58:27,892 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:58:27,895 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:59:06,022 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:59:06,024 ERR kernel:Buffer I/O error on device fd0, logical block 0
15:59:44,154 ERR kernel:end_request: I/O error, dev fd0, sector 0
15:59:44,155 ERR kernel:Buffer I/O error on device fd0, logical block 0
16:00:22,286 ERR kernel:end_request: I/O error, dev fd0, sector 0
16:00:22,288 ERR kernel:Buffer I/O error on device fd0, logical block 0
16:01:00,425 ERR kernel:end_request: I/O error, dev fd0, sector 0
16:01:00,426 ERR kernel:Buffer I/O error on device fd0, logical block 0
16:01:38,552 ERR kernel:end_request: I/O error, dev fd0, sector 0
16:01:38,552 ERR kernel:Buffer I/O error on device fd0, logical block 0
16:02:12,791 ERR udevd: worker [467] unexpectedly returned with status 0x0100
16:02:12,791 ERR udevd: worker [467] failed while handling '/devices/platform/floppy.0/block/fd0'
16:02:16,684 ERR kernel:end_request: I/O error, dev fd0, sector 0
16:02:16,685 ERR kernel:Buffer I/O error on device fd0, logical block 0

Almost 8 minutes. I definitely started to think that the install had hung during the "Finding storage devices" stage.

Comment 3 Orion Poplawski 2010-02-16 15:38:31 UTC
VT1 also displays:

udevadm settle - timeout of 300 seconds reached, the event queue contains: /sys/devices/platform/floppy.0/block/fd0

Something different about how udev is started/runs?

Comment 4 Chris Lumens 2010-02-16 16:15:36 UTC
anaconda tries its best to ignore floppy disks (see storage/udev.py:__is_blacklisted_blockdev), but we are still relying on hardware/kernel/udev to hurry up and tell us what devices are present.  We could perhaps hack up further udev rules to work around the underlying cause here, but no one likes when we do that.  Reassigning to kernel on the basis of the messages in comment #2.

Comment 5 Bug Zapper 2010-03-15 15:04:31 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Chuck Ebbert 2010-04-09 14:19:31 UTC
We tried to kill automatic floppy driver loading but the udev developers re-animated it.

Comment 7 Harald Hoyer 2010-04-09 14:29:21 UTC
just do

echo "blacklist floppy" > /etc/modprobe.d/nofloppy.conf

or if it is happening in initramfs/dracut "rdblacklist=floppy" to the kernel command line.

Comment 8 Harald Hoyer 2010-04-09 14:29:40 UTC
(In reply to comment #6)
> We tried to kill automatic floppy driver loading but the udev developers
> re-animated it.    

not in F13

Comment 9 Harald Hoyer 2010-04-09 14:30:52 UTC
(In reply to comment #6)
> We tried to kill automatic floppy driver loading but the udev developers
> re-animated it.    

what's the output of:

# grep -r floppy /etc/modprobe.d/
# rpm -qf $( grep -r floppy /etc/modprobe.d/ )

Comment 10 Orion Poplawski 2010-04-09 15:04:42 UTC
The installed system boots fine and does not probe for the floppy.  Just the installer.  The grep command comes up empty on the installed system and on the installer image.

Comment 11 Hans de Goede 2010-04-12 15:23:38 UTC
*** Bug 574492 has been marked as a duplicate of this bug. ***

Comment 12 Hans de Goede 2010-04-12 15:24:32 UTC
This is an anaconda issue not a kernel nor udev issue, see this thread on anaconda-devel-list:
http://www.redhat.com/archives/anaconda-devel-list/2010-March/msg00332.html

Comment 13 Patrick C. F. Ernzer 2010-04-14 14:58:35 UTC
This still happens on F13 Beta

Comment 14 Remi Collet 2010-04-18 06:20:35 UTC
With F-13 Beta, anaconda hangs during the "Finding storage devices" stage.
(I probably don't wait enough to see if it will continue after a long delay)

Install works fine when floppy controller disabled in BIOS.

Comment 15 Didier G 2010-04-18 11:16:09 UTC
Same problem with motherboard Gigabyte 790FXTA-UD5 if floppy drive is activated in BIOS but there is no floppy drive connected.

I have to wait 10 minutes of clock wall with no message before installation resume and during this time it looks like installating has hanged.

Comment 16 Mike Chambers 2010-04-24 20:33:44 UTC
When does this happen during install?  I got a hang when the very first gui welcome screen started, but the mouse/keyboard wasn't responsive.  I only waited just a minute or so.  Is this the same thing, waiting on floppy/whatever or is my problem something different?

Comment 17 Hans de Goede 2010-04-25 14:34:55 UTC
Anaconda loads the floppy driver during all installs for driver disk support. This is not something new but something which anaconda has done for ages. It seems that the problem with this causing a huge delay on some floppy less machines is something from more recent kernels.

Also this has been discussed on the Fedora kernel list, and a kenrel patch fixing this has been proposed, so I'm changing the component to kernel, see:
http://lists.fedoraproject.org/pipermail/kernel/2010-April/002394.html
http://lists.fedoraproject.org/pipermail/kernel/2010-April/002420.html

Comment 18 Hans de Goede 2010-04-28 19:04:21 UTC
*** Bug 586037 has been marked as a duplicate of this bug. ***

Comment 19 Patrick C. F. Ernzer 2010-05-26 17:06:05 UTC
Just for the record, this bug is still present in F13 GA

As far as I am concerned, this can be CLOSED WONTFIX, the hardware I am experiencing it on has been deprecated and will not be used in the future.

But other users experiencing the bug might have a different view.

Comment 20 Gilboa Davara 2010-06-04 12:23:05 UTC
I'm seeing this on a brand new Gigabyte GA-M61PME-S2P using preupgrade.
The machine is my HPC and connected to an LCD TV, so I can't go into the BIOS and disable the floppy drive controller.

I'll try blacklisting the floppy from the grub command line.

- Gilboa

Comment 21 Wim Cos 2010-08-12 17:05:16 UTC
rdblacklist=floppy as kernel parameter does not solve this issue.

This is what dmesg says during install:

end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0

Using the netinst.iso 32 bit.

Comment 22 Adam Pribyl 2010-08-12 20:30:25 UTC
Did you disabled FDD controller in BIOS, if floppy drive is not present?

Comment 23 megareg 2010-09-07 15:25:04 UTC
I have the same problem. Tried several install images (DVD, CD, 32bit, 64bit and the direct-upgrade from F11), still doesn't work. I tried the boot parameters acpi=off, rdblacklist=floppy, floppy.allowed_drive_mask=0 and disabling the floppy drive in the BIOS. No combination of these helped, some led to another error (595916). Disconnecting the cables from the floppy drive isn't working, too.

Comment 24 Mike Chambers 2011-04-24 13:42:14 UTC
Haven't seen any more errors on this or no one reporting them, so closing.


Note You need to log in before you can comment on or make changes to this bug.