Bug 56577 - System resources goes too high, load average also
System resources goes too high, load average also
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 06:33 EST by ferulisses
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 06:37:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
computer B top (1.52 KB, text/plain)
2001-11-21 06:34 EST, ferulisses
no flags Details
Computer C top (1.58 KB, text/plain)
2001-11-21 06:35 EST, ferulisses
no flags Details

  None (edit)
Description ferulisses 2001-11-21 06:33:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Win95; U)

Description of problem:
Using RedHat 7.2 (also 7.1) with kernel 2.4.x in some computers cause system resources to use all avaliable resources in
a few hours, depending on how much the system is used.

Version-Release number of selected component (if applicable): 2.4.7-10 and 2.4.3-12

How reproducible:
Always

Steps to Reproduce:
1. Install RedHat 7.2
2. Leave the computer running for few hours with high use.

	

Actual Results:  All resources are taken by system.

Expected Results:  Normal activity.

Additional info:

I was post the bug 40103 some time ago, in that time, I thinked that the problem was the SCSI controller, but now, I had the same problem in others 2 
computers, with different hardware configuration:

the 3 computers are:
A. Dual PIII 600Mhz,  Motherboard Intel N440BX, 512Mb RAM, 
    Sym53c875 SCSI, HDs Quantum QM39100TD-SW, Fujitso MAE3182LP
    Ether: 1 onboard EEPro 100Mbits, 1 3COM 905B 100Mbits
    video onboard cirrus logic
    my main proxy server, ~500 users, impossible to use in 1 or 2 hours.
    this is still RedHat 7.1, I was downgraded to kernel 2.2.16 and solved, like in bugzilla ID 40103
B. Single PII 400Mhz, Motherboard Intel 440BX (single), 256Mb RAM, 
    Sym53c875 SCSI, HD Quantum Atlas IV and Quantum Viking II
    Ether: 1 onboard EEPro 100Mbits, 1 offboard EEPro 100Mbits
    video onboard cirrus logic
    other proxy server, ~60 users, impossible to use in ~36 hours, 18 hours in high traffic days.
    this is RedHat 7.2, I reboot it every night to solve the problem.
C. Single PII 400Mhz, Motherboard unknow (maybe Asus or Soyo) with 440BX chipset, 192Mb RAM,
    Adaptec AIC-7861 SCSI, HD Quantum Fireball ST4.3S
    Ether: 1 3Com 905B 100Mbits and 1 3COM 905C 100Mbits
    video trident 9660
    other proxy server, ~150 users, impossible to use in ~12 hours.
    this is a new installation, presenting the same problem.

In all the instalations, I choosed minimum custom packages, for console only, resulting ~350Mb of
system files, used ext3 and ext2. Install ok, bootup ok, still stable if low use.

I run few programs:
named, squid, sendmail, radius (from radius-cistron package on Powertools) and ssh.

Special configuration ? I still use ipchains. I'm trying now leaving the computer B without ipchains,
I need to wait ~12 hours to know if this solves or not.

Follow attached the top from computers after some hours (before I need to reboot to continue using):
look at CPU states, the amount used by system.

If isn't possible to solve the problem in a few days, it's possible to downgrade to kernel 2.2.x with RedHat 7.2 and ext3 ?
Comment 1 ferulisses 2001-11-21 06:34:42 EST
Created attachment 38243 [details]
computer B top
Comment 2 ferulisses 2001-11-21 06:35:25 EST
Created attachment 38244 [details]
Computer C top
Comment 3 ferulisses 2001-12-09 07:56:16 EST
I made more tests, in another computer this don't happen, it's a
Pentium II 350Mhz, Motherboard Asus, 256Mb RAM,
HD Quantum IDE, Ether 3COM 905C 100Mbits.

the main difference is that there isn't SCSI controler, and the chipset
is a Via Apollo 3 instead of a Intel 440 BX.

I also changed firewall scripts to iptables, solved the problem in all the tree 
computers, but in this last computer I still use ipchains without problems.

Note You need to log in before you can comment on or make changes to this bug.