Bug 565778 - SELinux is preventing /usr/bin/perl "getattr" access on /var/spool/bacula/log.
SELinux is preventing /usr/bin/perl "getattr" access on /var/spool/bacul...
Status: CLOSED DUPLICATE of bug 494037
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:613a379ad26...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-16 04:21 EST by Renich Bon Ciric
Modified: 2010-02-22 16:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-16 10:53:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Renich Bon Ciric 2010-02-16 04:21:00 EST
Summary:

SELinux is preventing /usr/bin/perl "getattr" access on /var/spool/bacula/log.

Detailed Description:

SELinux denied access requested by logwatch. It is not expected that this access
is required by logwatch and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:logwatch_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_spool_t:s0
Target Objects                /var/spool/bacula/log [ file ]
Source                        logwatch
Source Path                   /usr/bin/perl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.10.0-87.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-84.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux introdesk.penthouse.net
                              2.6.31.12-174.2.3.fc12.x86_64 #1 SMP Mon Jan 18
                              19:52:07 UTC 2010 x86_64 x86_64
Alert Count                   6
First Seen                    Sun 14 Feb 2010 02:36:07 PM CST
Last Seen                     Tue 16 Feb 2010 03:17:02 AM CST
Local ID                      e55bd3be-b65c-4dc7-afbf-878c9608ff4b
Line Numbers                  

Raw Audit Messages            

node=introdesk.penthouse.net type=AVC msg=audit(1266311822.459:26): avc:  denied  { getattr } for  pid=4412 comm="logwatch" path="/var/spool/bacula/log" dev=dm-0 ino=1578309 scontext=system_u:system_r:logwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=file

node=introdesk.penthouse.net type=SYSCALL msg=audit(1266311822.459:26): arch=c000003e syscall=4 success=no exit=-13 a0=1e2e178 a1=1d92130 a2=1d92130 a3=1ec66b0 items=0 ppid=4406 pid=4412 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=2 comm="logwatch" exe="/usr/bin/perl" subj=system_u:system_r:logwatch_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,logwatch,logwatch_t,var_spool_t,file,getattr
audit2allow suggests:

#============= logwatch_t ==============
allow logwatch_t var_spool_t:file getattr;
Comment 1 Daniel Walsh 2010-02-16 10:53:25 EST

*** This bug has been marked as a duplicate of bug 494037 ***
Comment 2 Daniel Walsh 2010-02-16 10:54:46 EST
Miroslav, also add

/var/spool/bacula/log(/.*)? 	gen_context(system_u:object_r:var_log_t,s0)

Note You need to log in before you can comment on or make changes to this bug.