Bug 565848 - LVMError: lvactivate failed for lv_root: Skipping volume group vg_test1148
LVMError: lvactivate failed for lv_root: Skipping volume group vg_test1148
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:b3dcacf45ca17d5e5...
: CommonBugs
: 571955 (view as bug list)
Depends On:
Blocks: F13Beta/F13BetaBlocker
  Show dependency treegraph
 
Reported: 2010-02-16 09:31 EST by James Laska
Modified: 2013-09-02 02:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.35-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-19 10:46:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (244.75 KB, text/plain)
2010-02-16 09:31 EST, James Laska
no flags Details
Attached traceback automatically from anaconda. (320.64 KB, text/plain)
2010-02-16 09:49 EST, James Laska
no flags Details
Attached traceback automatically from anaconda. (279.22 KB, text/plain)
2010-02-26 06:28 EST, He Rui
no flags Details

  None (edit)
Description James Laska 2010-02-16 09:31:51 EST
The following was filed automatically by anaconda:
anaconda 13.26 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 408, in lvactivate
    raise LVMError("lvactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/anaconda/storage/devices.py", line 2250, in setup
    lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/deviceaction.py", line 312, in execute
    self.device.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 670, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 290, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1311, in nextClicked
    self.anaconda.dispatch.gotoNext()
LVMError: lvactivate failed for lv_root: Skipping volume group vg_test1148
Comment 1 James Laska 2010-02-16 09:31:54 EST
Created attachment 394555 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2010-02-16 09:33:52 EST
= Steps to reproduce =

1. Initiate install using *only* 2 of 4 previously formatted set of disks
2. Choose basic disk layout
3. Choose "replace all partitions" and select "Encrypt"
4. Enter a passphrase

I'll see how reproducable this is and whether it's specific to previous disk contents
Comment 3 James Laska 2010-02-16 09:49:19 EST
Created attachment 394560 [details]
Attached traceback automatically from anaconda.
Comment 4 James Laska 2010-02-16 09:56:32 EST
Certainly specific to the previous contents of the disk.  Wiping out the disks allows me to proceed past this error.
Comment 5 James Laska 2010-02-16 10:38:04 EST
= Reproducer =
1. Install an encrypted partition scheme using default partitions
2. After partitioning is complete, initiate another install
3. Choose default partition scheme and [X] encrypt

traceback
Comment 6 David Lehman 2010-02-16 19:18:17 EST
This is a known issue. Any preexisting lvm configurations using encrypted PVs will exhibit this behavior if you specify that the preexisting encrypted PVs be reformatted (not preserving the encryption).
Comment 7 James Laska 2010-02-18 19:05:44 EST
Per discussion with Dave on IRC, I'm adding this to F13Beta and noting for CommonBug documentation for the Alpha.  I think this might be common enough to note for Alpha users.

Recommended workaround is to disregard the passphrase prompt for existing encrypted partitions.
Comment 8 He Rui 2010-02-26 06:28:02 EST
Created attachment 396517 [details]
Attached traceback automatically from anaconda.
Comment 9 He Rui 2010-02-26 06:33:57 EST
steps:

1. System originally contained encrypted lvm.
2. Install a new system on it:

a. Delete all old partitions.
b. create ext4 /boot, ext4 /, swap manually.
Comment 10 Chris Lumens 2010-03-10 16:07:39 EST
*** Bug 571955 has been marked as a duplicate of this bug. ***
Comment 11 Bug Zapper 2010-03-15 11:05:33 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 James Laska 2010-03-18 09:09:42 EDT
This issue was discussed at the F-13 blocker bug review meeting.  It was agreed that this issue represents a Beta blocker.  While no specific criteria exists to ensure installing encrypted partitions on a system that already contains encrypted partitions, it was felt that the use case captured by this bug is common enough to consider addressing for F13 Beta.

dlehman: do you require additional information on this issue?
Comment 13 Fedora Update System 2010-03-18 13:12:50 EDT
anaconda-13.35-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.35-1.fc13
Comment 14 Fedora Update System 2010-03-18 13:12:55 EDT
anaconda-13.35-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.35-1.fc13
Comment 15 James Laska 2010-03-19 10:19:59 EDT
http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=2cef4cf3a2c7a22b6d0024c6048815d8ad6d74cc

Moving to MODIFIED since this is included in anaconda-13.35-1.fc13
Comment 16 James Laska 2010-03-19 10:20:42 EDT
Note, and additional commit addresses this issue (see http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=74c6e8cb0cc4dfe21b1d43a920c2ccf33f2c444b)
Comment 17 James Laska 2010-03-19 10:45:51 EDT
Confirmed this issue no longer occurs with anaconda-13.35-1.fc13
Comment 18 Fedora Update System 2010-03-22 22:25:54 EDT
anaconda-13.35-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.