This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 56589 - pump should have ability to verify lease periodically
pump should have ability to verify lease periodically
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 08:40 EST by Daniel Senie
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-06 17:40:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 2001-11-21 08:40:27 EST
Description of Problem:

I've noticed appliance devices (e.g. "broadband" routers, firewall 
appliances) verifying their leases frequently, like hourly, to be sure 
nothing has changed. This would be a nice addition to pump.

Version-Release number of selected component (if applicable):


How Reproducible:

100%

Whenever the local cable company decides to renumber their world (happens 
every other month or so), it's necessary to do a

 /etc/rc.d/init.d/network restart

to get pump to recheck DHCP. I expect the lease time is set to something 
long (dumb, if they're going to do renumbering). Having pump check hourly 
to verify its lease would "solve" the problem, since it'd discover it 
couldn't reach the DHCP server it thought it was talking to, and then do a 
discover and find the new one.

Steps to Reproduce:
1. set up DHCP server to give PUMP a 3 month lease
2. change addressing on the DHCP server system and daemon
3. see how long it takes for pump to decide to requery.

Actual Results:


Expected Results:


Additional Information:
	
It's sad that there are networks out there run poorly, requiring this kind 
of thing. Clearly the appliance vendors have seen the same issue 
and "solved" it by pestering the DHCP servers periodically. For Linux to 
work reliably in place of appliances in this kind of environment, the 
proposed enhancement would greatly help.
Comment 1 Daniel Senie 2002-01-06 17:40:23 EST
Though it's not well documented, pump uses a domain socket to communicate 
between a command line invocation and a running daemon. As such, it's possible 
to put the command:

  /sbin/pump -i eth0 --renew

into a script run from cron or in the cron.hourly or whatever, to achieve the 
desired effect. It'd still be nice if pump had a way to configure this 
internally, but at least there's a good work-around for now.

Note You need to log in before you can comment on or make changes to this bug.