Bug 56596 - Init fails when attempting to fsck root filesystem on with RAID 5 on a DAC960 controller
Init fails when attempting to fsck root filesystem on with RAID 5 on a DAC960...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 11:35 EST by Dennis Edmonds
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 11:35:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Edmonds 2001-11-21 11:35:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
When booting with the 2.4.9-13.i686 init will not fsck the root filesystems
properly.  It reports "Warning...fsck.ext3 for device /dev/rd/c0d0p4 exited
with signal 11.  Give root password for maintenance."  Manual fsck of the
filesystem also fail with a signal 11.  I have tried ext2 as well, but I
have only experienced the same result.

The only kernels this occurs with are the 2.4.9-7 and 2.4.9-13 i686. 
Everything works perfectly with 2.4.7-10.i686.  The i386 version of the
2.4.9 kernels seem to work fine as well, but I these do not support all of
the memory I have in my system (>1GB.)

The system is using the DAC960 module and has an AcceleRAID 352 controller
with hardware RAID5.  It is patched with the latest BIOS, firmware, etc
from Mylex and Asus (the motherboard) and is a Pentium4 1900.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up a system with an AcceleRAID 352 and RAID5
2. Boot with kernel 2.4.9-13.i686
3. Repeat

	

Actual Results:  Warning...fsck.ext3 for device /dev/rd/c0d0p4 exited with
signal 11

Give root password for maintenance:


Expected Results:  Should continue booting


Additional info:

System Config:

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 1
model name      : Intel(R) Pentium(R) 4 CPU 1.90GHz
stepping        : 2
cpu MHz         : 1917.124
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss tm
bogomips        : 3827.30

00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host
Bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP
Bridge (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801BAM PCI (rev 12)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (ICH2) (rev 12)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 12)
01:00.0 VGA compatible controller: nVidia Corporation Vanta [NV6] (rev 15)
02:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 10)
02:0a.0 PCI bridge: Intel Corporation 80960RP [i960 RP
Microprocessor/Bridge] (rev 02)
02:0a.1 RAID bus controller: Mylex Corporation: Unknown device 0050 (rev 02)
02:0b.0 Communication controller: Digi International: Unknown device 0029
(rev 02)
02:0c.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100]
(rev 0c)02:0d.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro
100] (rev 0c)

Mylex Controller is an AcceleRAID 352

Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/rd/c0d0p4        24889368   7278856  16346200  31% /
/dev/rd/c0d0p1          124427      6055    111948   6% /boot
none                    514452         0    514452   0% /dev/shm
/dev/rd/c0d0p2         8159420    130772   7614172   2% /var
Comment 1 Dennis Edmonds 2002-01-02 11:37:09 EST
Problem is no longer present in rawhide kernel-2.4.9-17.6.


Note You need to log in before you can comment on or make changes to this bug.