Bug 56598 - stale /var/run/amd.pid file breaks amd startup script.
stale /var/run/amd.pid file breaks amd startup script.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: am-utils (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 12:07 EST by Eugene Kanter
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 13:54:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2001-11-21 12:07:45 EST
Description of Problem:

The root cause: amd does not remove its /var/run/amd.pid file when asked 
to exit.

The result:

impossible to start/restart amd using /etc/rc.d/init.d/amd scripts.

Version-Release number of selected component (if applicable):

am-utils-6.0.6-3

How Reproducible:

always.

Steps to Reproduce:
1. stop amd: service amd stop
2. start amd from command line: amd -F /etc/amd.conf
3. stop amd from command line: kill -TERM `cat /var/run/amd.pid`
4. attempt to restart amd: service amd restart: nothing happends:
Stopping amd:
Starting amd:
5. service amd status:

amd dead but pid file exists

Actual Results:

see above.

Expected Results:

service amd restart should be able to recover from "amd dead but pid file 
exists" situation.
Comment 1 Eugene Kanter 2005-08-28 16:54:53 EDT
This bug was CLOSED RAWHIDE without providing fixed package version. Please add
minimum description of what was done.

Note You need to log in before you can comment on or make changes to this bug.