Bug 56600 - [i2o] boot stop when mount filesystem
[i2o] boot stop when mount filesystem
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 12:52 EST by miguel soares
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 18:39:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description miguel soares 2001-11-21 12:52:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
I install RH linux 7.2 on a server machine with Intel server raid 
controller srcu31l controlling two drives. It install Ok, but when boot it 
fail to mount root filesystem (error 19 mounting ext3) and gives a kernel 
panic (no init found).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.on boot
2.
3.
	

Additional info:
Comment 1 Arjan van de Ven 2001-11-21 12:55:33 EST
Do you have ANY idea what driver is used for this card ?
Comment 2 miguel soares 2001-11-22 04:39:41 EST
no.
Comment 3 Arjan van de Ven 2001-11-22 04:46:58 EST
Did you use additional driver disks or did the installer on the cd support this
card directly ?
Comment 4 miguel soares 2001-11-22 08:26:39 EST
I didn't use any additional drivers because the CD supplied by Intel only 
supports RedHat 6.2 and on their site there insn't any driver for 7.2.

Red Hat recognized the card as i2o_block and loads the driver properly and 
finds all my partitions.

The server as an SBT2 Intel motherboard and the board has an Adaptec SCSI 
controller. I already tried to enable this controller, and installed RedHat 
again for it to recognize both controllers (aic7xxx and i2o_block). Then i 
booted from the rescue option on the RedHat CD, and edited the /etc/grub.conf 
and /etc/fstab to point to /dev/sdax instead of /dev/i2o/hdax. Then I connected 
on of the disks to the Adaptec controller and booted RedHat and it booted fine. 

After that i upgraded the kernel to version 2.4.9-13 to see if it would boot 
from the RAID controller. After the upgrade I edited once again 
the /etc/grub.conf and /etc/fstab to the original devices and connected the 
hardisk to the RAID controller.

After all this I continue to get the same error.

Server specs:
Intel SC5000 server chassis
Intel SBT2 Server Board
2 x Intel Pentium III Xeon - 1Ghz
1Gb RAM
Intel Server RAID Controller U3-1L (SRCU31L)
2 x 36Gb SCSI Quantum Atlas

Comment 5 Alan Cox 2003-06-07 18:39:06 EDT
Every attempt I made to get docs on this specific controller failed. The i2o
drivers support other devices reliably. I'm forced to conclude this is a problem
with the firmware on the controller, sorry but there isnt any way I can see we
can fix this.

Note You need to log in before you can comment on or make changes to this bug.