Bug 566010 - Setting up Logical Volume Management: File-based locking initialisation failed.
Setting up Logical Volume Management: File-based locking initialisation failed.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
13
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Rajnoha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-16 16:34 EST by Bill Nottingham
Modified: 2014-03-16 23:22 EDT (History)
16 users (show)

See Also:
Fixed In Version: lvm2-2.02.73-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-11 05:00:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2010-02-16 16:34:23 EST
+++ This bug was initially created as a clone of Bug #561938 +++


Installing with default partitioning (use entire drive, lvm based) gives an error message after rebooting into installed system:
Setting up Logical Volume Management:   File-based locking initialisation failed.
  /dev/mapper/vg_ibmjs206-lv_swap: lsetfilecon failed: Permission denied
  2 logical volume(s) in volume group "vg_ibmjs206" now active
[  OK  ]

--- Additional comment from prajnoha@redhat.com on 2010-02-08 07:48:48 EST ---

OK, after further investigation, there was a slight change in v 2.02.60 - it adds more messages when locking initialisation fails. But when booting, we use "--ignorelockingfailure" option because the filesystem is remounted read-write only later on within the boot process.

So we just need to suppress those messages when "--ignorelockingfailure" is used since the "failure" is expected.

(..however, the symptoms were very similar to the bug with lvm library I've described before. So if you install udisks package you'll see the same :))

--- Additional comment from prajnoha@redhat.com on 2010-02-15 14:24:08 EST ---

We have added LVM_SUPPRESS_LOCKING_FAILURE_MESSAGES environment variable to disable those warnings and errors if needed. The patch has been posted to upstream lvm2.

I notified the initscript team to use this in the rc.sysinit, so I'm waiting for the response now...
Comment 1 Bill Nottingham 2010-02-16 16:34:48 EST
Cloning for rawhide to get a better fix rather than settng a magic environment variable.
Comment 2 Bug Zapper 2010-03-15 11:08:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Peter Rajnoha 2010-05-10 06:29:02 EDT
(In reply to comment #1)
> Cloning for rawhide to get a better fix rather than settng a magic environment
> variable.    

A new --sysinit option has been added for vgchange and lvchange to provide a single shortcut for setting all options needed, including the functionality of LVM_SUPPRESS_LOCKING_FAILURE_MESSAGES.

It should appear in next lvm2 release (rc.sysinit will be changed accordingly to use this option instead of all the ones it uses today to provide better maintenance with respect to lvm2).
Comment 4 Fedora Update System 2010-08-26 14:46:31 EDT
lvm2-2.02.73-2.fc13,udisks-1.0.1-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lvm2-2.02.73-2.fc13,udisks-1.0.1-4.fc13
Comment 5 Fedora Update System 2010-08-30 14:29:52 EDT
lvm2-2.02.73-2.fc13, udisks-1.0.1-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lvm2 udisks'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lvm2-2.02.73-2.fc13,udisks-1.0.1-4.fc13
Comment 6 Fedora Update System 2010-09-11 05:00:40 EDT
lvm2-2.02.73-2.fc13, udisks-1.0.1-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Niels Mayer 2010-10-20 21:43:51 EDT
This issue happens also in Fedora 12 (2.6.32.21-168.fc12.x86_64)

Setting hostname gnulem:  [60G[[0;32m  OK  [0;39m]
Setting up Logical Volume Management:   File-based locking initialisation failed.
  1 logical volume(s) in volume group "vg_gnulem" now active
[60G[[0;32m  OK  [0;39m]
Checking filesystems
/dev/mapper/vg_gnulem-lv_root: clean, 1897821/30130176 files, 96323594/120512512 blocks
/dev/md0: clean, 51/51200 files, 29762/204736 blocks
[60G[[0;32m  OK  [0;39m]
Remounting root filesystem in read-write mode:  [60G[[0;32m  OK  [0;39m]
Mounting local filesystems:  [60G[[0;32m  OK  [0;39m]
...

Note You need to log in before you can comment on or make changes to this bug.