Bug 56606 - slapadd does not reload LDAP database correctly
slapadd does not reload LDAP database correctly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 15:50 EST by John Dalbec
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 15:50:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dalbec 2001-11-21 15:50:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Windows NT 5.0; U)

Description of problem:
After running slapadd on an empty /var/lib/ldap, all searches fail with 32 no such object.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. service ldap stop
2. slapindex
Do I need the -f /etc/openldap/slapd.conf here?  Or did you compile that in?
3. slapcat > foo.ldif
4. mv /var/lib/ldap /var/lib/ldap.old
5. mkdir /var/lib/ldap
6. chown ldap:ldap /var/lib/ldap
7. chmod 700 /var/lib/ldap
Do I need to start and stop the server here to fill in some items?
8. slapadd -c < foo.ldif
9. slapindex
10. service ldap start
11. ldapsearch -x 'uid=jpdalbec'
	

Actual Results:  32 no such object

Expected Results:  0 success and a listing of my record

Additional info:

I wanted to rebuild the database because some object classes I added are not indexing correctly.  If I do a search on 
'(&(uid=...)(objectClass=eduPerson))' I get no results for some uids even though I can see the object class in the listing of their record.
Comment 1 John Dalbec 2001-11-26 08:30:48 EST
Sorry, I forgot the first rule of *n*x systems administration:  when in doubt, it's a permissions problem.
I fixed my original problem with chown -R ldap:ldap /var/lib/ldap and another slapindex.

Note You need to log in before you can comment on or make changes to this bug.