Bug 56613 - (IDE VIA)Hang when writing to (sync or umount) Zip disk.
(IDE VIA)Hang when writing to (sync or umount) Zip disk.
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-21 19:26 EST by Chris Cogdon
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-07 18:44:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Cogdon 2001-11-21 19:26:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
(This might not be the most appropriate forum to announce this bug, but it 
sure would have helped me if this was here when I started looking for the 
problem. Apols in advance.)

Problem when writing data to a IDE/Internal ZIP disk from Redhat 7.1 
(kernel package version 2.4.2-2 or 2.4.9-6) as well as earlier, kernel 
2.2.x based distributions.

When writing any largish (say, over a couple of blocks) files to the zip 
drive, a sync or umount /mnt/zip command will hang, and eventually return 
kernel error messages. Reads, and smaller writes, appear to work fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run redhat-7.1 on a Athlon system with the Via 82C686B chipset)
2. Mount a IDE Internal ZIP drive
3. Write some data... at least 1MB
4. Umount the ZIP disk

Actual Results:  The write will appear to work, but the umount 
will 'hang'. The kernel will eventually report these errors:

hdd: lost interrupt 
ide-floppy: CoD != 0 in idefloppy_pc_intr 
hdd: ATAPI reset complete 

If a 'sync' is issued instead, 'sync' will hang in a similar fashion, 
including the errors.

Expected Results:  Data written and umount (or sync) returns.

Additional info:

After about 2 days research (which is why I'm so keen to tell SOMEONE 
about this... don't want all that time wasted). I found that there's a 
problem with the Via chipset as used with the Athlon motherboards. I tried 
the above on two motherboards with a Athlon 1200MHz and 1400MHz, with the 
same error; they used the same chipset. EXactly the same equipment, but 
with a intel CPU and motherboard, worked just fine.

Here's an example of a windows user with a similar problem: 

And a linux user:
Comment 1 Alan Cox 2003-06-07 18:44:21 EDT
Later IDE knows ab out this so ought to be reliable. If not please re-open

Note You need to log in before you can comment on or make changes to this bug.