Bug 56616 - /sbin/dump in RedHat 7.2 sometimes hangs forever
Summary: /sbin/dump in RedHat 7.2 sometimes hangs forever
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dump   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 58440 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-22 03:12 UTC by zpenguin
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-22 13:31:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description zpenguin 2001-11-22 03:12:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
On very large filesystems, /sbin/dump sometimes hangs
forever.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to run dump using multi-volume mode (-M) and save a very
   large filesystem on the order of 11GB with many files.

	

Actual Results:  /sbin/dump goes idle and does nothing.


Expected Results:  /sbin/dump should have completed the dump
of the entire filesystem.

Additional info:

This bug is trivial to fix.
When I recompiled dump using
version 0.4b22, dump completes
normally.

I don't really know what the difference
is between the RedHat version and my own
compiled version, but something made
a difference.  My compiled dump is dynamically
linked and the one in RedHat 7.2 at /sbin/dump
is statically linked.  It's possible that there
is some statically linked library code that's
out of date.

I recommend recompiling dump and restore and
just put a new RPM out there.  It can only help.

I've also had this problem with RedHat 7.1 by the
way and solved it in a similar way.

Comment 1 Mike A. Harris 2001-11-22 04:05:34 UTC
This is fixed in dump 0.4b25 which I have just built internally.
It should be available in rawhide shortly.  Can you confirm the
fixed version works for you?

Comment 2 zpenguin 2001-11-22 13:31:33 UTC
Yes, I can rerun my entire backup job using the
newly compiled version.


Comment 3 Mike A. Harris 2001-11-23 00:17:19 UTC
Great, thanks

Comment 4 zpenguin 2001-11-24 13:30:43 UTC
I reran my network backup.
The entire job ran without any problems
including the 11GB dump.

+ sh -c '/auto/sw/dump/0.4b25-1/sbin/dump -T "Wed Dec 31 19:00:00 1969" -B
1500\000 -M -f
/auto/backup-c700-0/dump/time-range/from-1969-12-31/19-00-00--0500/to-2001-11-23/09-36-15--0500/celeron600-0.xxxxxxxxx-pn.com/auto-local.dump
/auto-\local'
DUMP: Date of this level 0 dump: Fri Nov 23 09:38:24 2001
DUMP: Dumping /dev/hdd3 (/auto-local) to
/auto/backup-c700-0/dump/time-range/from-1969-12-31/19-00-00--0500/to-2001-11-23/09-36-15--0500/celeron600-0.xxxxxxxx\x-pn.com/auto-local.dump001
DUMP: Added inode 8 to exclude list (journal inode)
DUMP: Added inode 7 to exclude list (resize inode)
DUMP: Label: /auto-local
DUMP: mapping (Pass I) [regular files]
DUMP: mapping (Pass II) [directories]
DUMP: estimated 11384281 tape blocks on 7.59 tape(s).
DUMP: Dumping volume 1 on
/auto/backup-c700-0/dump/time-range/from-1969-12-31/19-00-00--0500/to-2001-11-23/09-36-15--0500/celeron600-0.xxxxxxxxx-pn.com/auto-local.dump001
   .
   .
   .
DUMP: 11505810 tape blocks (11236.14MB) on 8 volume(s)
DUMP: finished in 1792 seconds, throughput 6420 kBytes/sec
DUMP: Date of this level 0 dump: Fri Nov 23 09:38:24 2001
DUMP: Date this dump completed: Fri Nov 23 10:08:53 2001
DUMP: Average transfer rate: 6451 kB/s
DUMP: DUMP IS DONE


Comment 5 Mike A. Harris 2002-01-28 13:13:37 UTC
*** Bug 58440 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.