Bug 5662 - 6.1 upgrade causes fsck error on boot
6.1 upgrade causes fsck error on boot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-06 21:08 EDT by piller
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-22 14:27:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description piller 1999-10-06 21:08:01 EDT
I have upgraded 3 machines from RH 6.0 to RH 6.1 and two of
the machines now fail the boot up process with a warning
about a partition or fsck error and kick me into a shell to
allow me to fix the problem (which so far I have not).
I run fsck on all of my paritions (/, /home/, /usr, /opt,
/tmp, /var) and they are clean with no problem.  I can
manually mount each partition and run the machine as root
user, network, you name it but when I reboot I get the same
error. I need to figure this out quick or save my data and
do a fresh install.
Comment 1 piller 1999-10-07 09:05:59 EDT
I posted this one, have now fixed problem.  Apparently the upgrade
changed the filesystem mount options in /etc/fstab so the filesystems
do not auto mount at boot.  To fix change the mount options to
"defaults" or add "auto" to the mount option list in /etc/fstab.
Comment 2 Tom Moertel 1999-10-17 10:00:59 EDT
I had the same problem: false fsck error occurring on bootup after
having upgraded from RH 5.2 to 6.1.  I fixed it by adding the -s
option to the second call to fsck in rc.sysinit:

  initlog -c "fsck -C -T -R -A -a -s $fsckoptions"

Works like a charm, but at the cost of parallel fsck checks on my
drives.
Comment 3 Jay Turner 1999-10-20 16:15:59 EDT
This issue has been assigned to a developer for further action.
Comment 4 Jay Turner 1999-10-22 14:27:59 EDT
Not able to replicate in test lab.  Send more information if you are
able to provide more specific examples.
Comment 5 Isak Prohovnik 1999-12-14 09:57:59 EST
After upgrade to 6.1, and following several successful configurations and
reboots, on one reboot it refused to mount /var; althopugh fsck reported
'clean', it also reported 'failed' and dropped me into root logi

Note You need to log in before you can comment on or make changes to this bug.