Bug 566269 - Unable to add DVD package repository during reposetup
Unable to add DVD package repository during reposetup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Target 576542
  Show dependency treegraph
 
Reported: 2010-02-17 13:31 EST by James Laska
Modified: 2013-09-02 02:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-14.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 576542 (view as bug list)
Environment:
Last Closed: 2011-03-07 13:01:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot.png (97.30 KB, image/png)
2010-02-17 13:31 EST, James Laska
no flags Details
anaconda-logs.tgz (/tmp/*) (482.87 KB, application/octet-stream)
2010-02-17 13:38 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2010-02-17 13:31:57 EST
Created attachment 394789 [details]
Screenshot.png

Description of problem:

If I PXE boot the installer, and use a remote install.img (where repo= and stage2=http://someserver/path/to/install/source), I am unable to add a CD/DVD package repository in the reposetup step.  While I can mount the inserted DVD from tty2, the UI indicates that no installation media was found.

Version-Release number of selected component (if applicable):
 
 * anaconda-13.26 (plus http://jlaska.fedorapeople.org/updates-f13-alpha-tc2.img)

How reproducible:

 * 3 of 3 attempts

Steps to Reproduce:

 * Follow instructions at https://fedoraproject.org/wiki/QA:Testcase_Additional_CDDVD_Repository
  
Actual results:

See attached screenshot.

Expected results:

The DVD should be accepted as a valid package repo

Additional info:
 * Will attach /tmp from anaconda (including all log files)
 * While the Fedora alpha release criteria (https://fedoraproject.org/wiki/Fedora_13_Alpha_Release_Criteria) indicate that loading package from a DVD package repository is required, I believe this is a degenerate case in that I'm not booting from the DVD, but instead PXEbooting and later attempting to add a local DVD package repository.
Comment 1 James Laska 2010-02-17 13:38:16 EST
Created attachment 394791 [details]
anaconda-logs.tgz (/tmp/*)
Comment 2 Radek Vykydal 2010-03-23 07:19:09 EDT
I sent a patch for review: https://www.redhat.com/archives/anaconda-devel-list/2010-March/msg00297.html
Comment 3 James Laska 2010-03-23 19:41:38 EDT
No explicit release criteria for this use case, so I don't think we should block release on this.  But it's a nice to have fix with what seems to be a low-impact patch.  Adding to F13Target.
Comment 4 Radek Vykydal 2010-03-24 06:22:00 EDT
This should be fixed in master, anaconda 14.2.
Comment 5 Bug Zapper 2010-07-30 06:51:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.