Bug 566284 - system-setup-keyboard not built with $RPM_OPT_FLAGS
system-setup-keyboard not built with $RPM_OPT_FLAGS
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-setup-keyboard (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2010-02-17 14:28 EST by Ville Skyttä
Modified: 2010-02-17 23:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 23:58:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix target dependencies in Makefile (529 bytes, patch)
2010-02-17 14:28 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2010-02-17 14:28:35 EST
Created attachment 394798 [details]
Fix target dependencies in Makefile

system-setup-keyboard is not built with $RPM_OPT_FLAGS due to Makefile dependency issues - it gets built fine in %build with the proper flags, but then again without any flags in %install.  Fix attached, should be upstreamable.
Comment 1 Peter Hutterer 2010-02-17 23:58:06 EST
Thanks for the patch, pushed to upstream.

Updated package is system-setup-keyboard-0.8.1-1.fc14.

Note You need to log in before you can comment on or make changes to this bug.