Bug 56630 - (PCI IRQ_ROUTING)System warps forward during backup via ide-tape
Summary: (PCI IRQ_ROUTING)System warps forward during backup via ide-tape
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-22 17:27 UTC by Bernd Bartmann
Modified: 2008-08-01 16:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:39:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Bartmann 2001-11-22 17:27:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
This is related to Bug 56436 so read this one first!

Ok Guys, now I think I've found the reason why I have problems with my
system time. After some tests with ntpdate running once a hour overnight
and every 5 minutes while my backup was running I figured out that there
seems to be a problem within the kernel ide-tape driver. I'm running
RedHat 7.2 official update kernel 2.4.9-13. Some details about my
hardware:
Abit ST6-RAID mainboard, i815 chipset
Celeron 1 Ghz
512 MB RAM
Onstream DI30-FAST IDE streamer (connected as master to second channel
of the onboard HPT370 ide controller)

My backup to the Onstream streamer start at 2:00 and ends around 3:15.
During this time the system time warps nearly 10 minutes forward as
monitored by ntpdate. This time warping only happens during backup and
is definitly reproducable. During the rest of the day the clocks only
drifts about 6 seconds, which is the expected behaviour.

I never had this problem with RedHat 7.0 and my hand-made kernel 2.2.18
containing the ide and raid patches.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. use ntpdate to sync your system time
2. do a backup to an Onstream DI30 IDE tape streamer
3. use ntpdate again to monitor how much your system clocks has drifted in
the meantime
	

Additional info:

Comment 1 Bernd Bartmann 2001-11-23 15:39:55 UTC
Tonight I ran the backup using the osst driver instead of the ide-tape driver
but nevertheless I get the same result. My system did again warp 10 minutes
forward (around 45 sec. per 5 minutes) during backup.


Comment 2 Bernd Bartmann 2003-07-30 16:48:00 UTC
I'm still seeing this time wrap issue (actually the time wraps back or stands
still for a while) on kernel 2.4.18-27.7.x.

I tried the latest errata kernel 2.4.20-19.7 but this one won't even boot on my
system (see bug #91033)

Comment 3 Bugzilla owner 2004-09-30 15:39:17 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.