Bug 56633 - cron generating yp_all errors
cron generating yp_all errors
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-22 13:43 EST by Tim Clarke
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 18:37:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clarke 2001-11-22 13:43:25 EST
Description of Problem:

I regularly see the following error mailed out of cron on 572 SMP
machines:-

yp_all: clnt_call: RPC: Timed out


I see this error even when the cron entry has stdout/stderr redirected as
in the following example:-

0,10,20,30,40,50 * * * * /etc/DaemonKeeper monitor 1>/dev/null 2>/dev/null

These errors also appear to be generated by /etc/cron.d/kmod


The error seems to be non-fatal, but generates a lot of noise.


Version-Release number of selected component (if applicable):

RedHat 6.2
2.2.16-3smp kernel
vixie-cron-3.0.1-40

I cannot say definitively whether this occurs under RedHat7.1 as our main
application will not yet run reliably with this OS and so the machines
running 7.1 are under a very light load. My feeling is that it does still
occur. I have NOT noticed this error on a 7.1 machine which is NOT running
nis.


How Reproducible:

approx 50 occurrences per day on some machines

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
	
I will try working around this by setting MAILTO="" and writing a script to
filter the cron outputs, i.e.;

*/10 8-19 * * 1-5 /usr/local/bin/mesgmon 2>&1 | filterscript


I have seen over 1000 of these emails generated in a 1-hour period, so
procmail is not really an option.

Regards.....Tim
Comment 1 Jason Vas Dias 2004-08-10 18:37:21 EDT
Just clearing out old bugs here.
This looks to be a NIS configuration problem.
vixie-cron-4.1-+ in Fedora can now use NIS with
no problems.

Note You need to log in before you can comment on or make changes to this bug.