Bug 566379 - Review Request: perl-Ham-Reference-QRZ - Ham::Reference::QRZ perl modul
Summary: Review Request: perl-Ham-Reference-QRZ - Ham::Reference::QRZ perl modul
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-18 09:18 UTC by Jens Maucher
Modified: 2010-03-01 18:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-01 18:50:51 UTC
mtasaka: fedora-review+
tibbs: fedora-cvs+


Attachments (Terms of Use)

Description Jens Maucher 2010-02-18 09:18:33 UTC
Spec URL: http://jensm.fedorapeople.org/perl-Ham-Reference-QRZ.spec
SRPM URL: http://jensm.fedorapeople.org/perl-Ham-Reference-QRZ-0.02-1.fc13.src.rpm

rpmlint /var/lib/mock/fedora-rawhide-x86_64/result/perl-Ham-Reference-QRZ-0.02-1.fc13.src.rpm 
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

Description: 
An object oriented front end for the QRZ.COM Amateur Radio callsign database

Comment 1 Mamoru TASAKA 2010-02-22 18:07:24 UTC
Some notes:

* License
  - For this package the license tag should be "GPL+ or Artistic".
    ref:
    https://fedoraproject.org/wiki/Packaging/Perl#License_tag

* Summary
  - Please improve Summary (please check the description in
    "abstract:" item of META.yml file)

* URL
  - We usually use http://search.cpan.org/dist/<module name> .
    For this package, it is http://search.cpan.org/dist/Ham-Reference-QRZ/

* SourceURL
  - Recent spec file generated by cpanspec seems to use
    http://www.cpan.org/modules/by-module/Ham/Ham-Reference-QRZ-%{version}.tar.gz

* BuildArch
  - This package should create noarch binary rpm ("BuildArch: noarch" is needed)

* Requires
  - Usually dependencies related to perl module based rpms are
    automatically detected by rpmbuild itself.
    For this package, "Requires: perl(LWP::UserAgent)" is automatically
    added by rpmbuild and is not needed to be written explicitly.

  - Please check the following URL:
    https://fedoraproject.org/wiki/Packaging/Perl#Versioned_MODULE_COMPAT__Requires

Comment 2 Jens Maucher 2010-02-22 19:02:51 UTC
perl(XML::Simple) as a dependency is also available as rpm in the database, so it is automatically added.
perl(XML::Simple) is also not needed in %Requires?

Comment 3 Jens Maucher 2010-02-22 19:24:04 UTC
Ham::Reference::QRZ 0.02 is only available in http://www.cpan.org/modules/by-module/Ham/BRADMC/

The older version (0.01) is available under the link you posted in #1

Comment 5 Jens Maucher 2010-02-22 19:34:17 UTC
Edit:
SRPM URL: http://jensm.fedorapeople.org/perl-Ham-Reference-QRZ-0.02-2.fc12.src.rpm


I hate it, it would be cool if it were possible editing the own posts. -.-

Comment 6 Mamoru TASAKA 2010-02-24 18:07:03 UTC
For -2:

* Module compat Requires for perl modules
  - You don't seem to have addressed:
    https://fedoraproject.org/wiki/Packaging/Perl#Versioned_MODULE_COMPAT__Requires

    Please add MODULE_COMPAT Requires

* BuildRequires for tests
  - build.log shows:
--------------------------------------------------------
    82  t/00-load.t ....... ok
    83  t/pod-coverage.t .. skipped: Test::Pod::Coverage 1.08 required for testing POD coverage
    84  t/pod.t ........... skipped: Test::Pod 1.22 required for testing POD
--------------------------------------------------------
    Please add "perl(Test::Pod::Coverage)" "perl(Test::Pod)" to
    BuildRequires to enable the latter 2 tests.

Comment 7 Jens Maucher 2010-02-24 19:33:14 UTC
Ok, i uploaded the new spec (link above) and a new SRPM

http://jensm.fedorapeople.org/perl-Ham-Reference-QRZ-0.02-3.fc12.src.rpm

Comment 8 Mamoru TASAKA 2010-02-25 15:32:06 UTC
-----------------------------------------------------------------
  This package (perl-Ham-Reference-QRZ) is APPROVED by mtasaka
-----------------------------------------------------------------

Comment 9 Jens Maucher 2010-02-26 17:03:04 UTC
New Package CVS Request
=======================
Package Name: perl-Ham-Reference-QRZ
Short Description: An object oriented front end for the QRZ.COM Amateur Radio call-sign database
Owners: jensm
Branches: F-12 F-13

Comment 10 Jason Tibbitts 2010-02-26 17:53:30 UTC
CVS done (by process-cvs-requests.py).

Comment 11 Mamoru TASAKA 2010-03-01 18:50:51 UTC
Closing.


Note You need to log in before you can comment on or make changes to this bug.