This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 56638 - fdisk problem with cpqarray
fdisk problem with cpqarray
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
: 57892 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-22 21:14 EST by Jose Celestino
Modified: 2007-04-18 12:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 13:19:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jose Celestino 2001-11-22 21:14:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.14 i686)

Description of problem:
fdisk messes geometry of SmartArray2 logical drives. fdisk appear confuse
when working with Compaq SmartArray2 logical drives. It sees the drives as
1 cylinder drives, and when in the face of already parititioned disks it
sees the partitions borders mangled.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Installing RedHat Linux on SmartArray2 drive.

Actual Results:  fdisk wouldn't see the drives geometry as expected.

Expected Results:  fdisk should have been able to partition the drives.

Additional info:

This happened (always) on:

Compaq Proliant DL580
2 Gb Ram
9 Gb UW3 10 k
-> 2 in raid 1
-> 1 in raid 0
2 Xeon 700Mhz
2 DualPort intel EtherExpressPor100
Comment 1 Nigel Rice 2001-12-11 04:42:47 EST
the previous version of fdisk works fine with the compaq array
Comment 2 David Wilson 2002-01-01 18:46:31 EST
*** Bug 57892 has been marked as a duplicate of this bug. ***
Comment 3 David Wilson 2002-01-02 18:01:26 EST
As I found in Bug 57892, this seems to be caused by use of HDIO_GETGEO_BIG 
ioctl which is not supported by all drivers. Building a fresh (non RedHat 
source) fdisk which uses HDIO_GETGEO instead works for me.
Comment 4 Elliot Lee 2002-01-04 15:58:31 EST
Eventually HDIO_GETGEO_BIG usage will be removed, since it is unnecessary and
causes problems.
Comment 5 Elliot Lee 2002-01-29 16:42:40 EST
I think the util-linux in rawhide should fix this - please give it a try (you
may need to recompile from .src.rpm)
Comment 6 Christian Jacobsen 2002-05-22 09:31:02 EDT
I am having the same problem on 3 of 8 Compaq ML370 with Onboard RAID 
Controller.
What wonders me is that not all behave the same !?
The installation is the same on all of them. 

Christian Jacobsen

Note You need to log in before you can comment on or make changes to this bug.