Bug 5664 - installation messes up symlinks
installation messes up symlinks
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-06 22:00 EDT by mw
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-14 08:04:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mw 1999-10-06 22:00:29 EDT
I thinks this has nothing to do with the symlinks package
---but I had to choose a component.

I just upgraded to 6.1 (via ftp) from 6.0.  I chose to
upgrade, and not to customize the packages to upgrade. I was
 almost at the end of the installation when I get an error
 message that  prompts me if I want to debug.  I did not, so
 the system went down, but could never come back.

With my old rescuse disk, I booted, and noticed that / was
 full. The reason it was full was that my three symlinks

doc -> ../hda5/usr/doc
share -> ../hda5/usr/share
src -> ../hda5/usr/src

in /usr got removed by the installation, and got replaced by
 actual directories

/usr/doc, /usr/share, /usr/src

This of course, ate up the 300+M freespace on /.

Curious, I verified this behavior one more time: I
 reinstated the symlinks, again ran the upgrade, and again
 the above symlinks got removed.

Here is the relevan partition table, in case you decide to
 try to duplicate my observation:

/dev/hda1   *         1       128   1028128+  83  Linux
/dev/hda2           129       525   3188902+   5  Extended
/dev/hda5           129       218    722893+  83  Linux
/dev/hda6           219       308    722893+  83  Linux
/dev/hda7           309       317     72261   82  Linux swap

Mate

------- Additional Comments From   10/20/99 17:11 -------
It seems it is crucial that my symlinks are *relative* symlinks.
When I use absolute links, all seem well.

Mate
Comment 1 Jay Turner 2000-02-14 08:04:59 EST
I was able to perform an upgrade from 6.1 to the beta for 6.2 without any
problems.  Note that I was using symbolic links for this upgrade.  So, I think
this issue might be resolved.  Please reopen if you are still having problems.

Note You need to log in before you can comment on or make changes to this bug.