Bug 566420 - QEMU can create disk with size zero but can not run it. Creation of zero size disk should be forbidden.
QEMU can create disk with size zero but can not run it. Creation of zero size...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-02-18 07:54 EST by Leonid Natapov
Modified: 2011-01-14 11:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-14 11:40:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Natapov 2010-02-18 07:54:03 EST
QEMU can create disk with size zero but can not format it or run it. Creation of zero size disk should be forbidden.

[root@dhcp-1-143 ~]# qemu-img create -f qcow2 test 0 Formatting 'test', fmt=qcow2, size=0 kB
[root@dhcp-1-143 ~]# qemu-img convert -f qcow2 test test2
qemu-img: Could not open 'test'
Comment 2 Alan Pevec 2010-02-18 08:23:45 EST
please provide kvm version
Comment 3 Leonid Natapov 2010-02-18 08:30:36 EST
[root@magenta-vdsa ~]# rpm -qa | grep qemu
kvm-qemu-img-83-155.el5
vdsm-faqemu-4.5-27
gpxe-roms-qemu-0.9.7-8.el5
[root@magenta-vdsa ~]# rpm -qa | grep kvm
kvm-qemu-img-83-155.el5
kvm-83-155.el5
etherboot-zroms-kvm-5.4.4-13.el5
kmod-kvm-83-155.el5
kvm-tools-83-155.el5
Comment 4 Kevin Wolf 2010-07-01 06:19:35 EDT
If anything, we should allow opening zero-sized images as in RHEL6. Patch would be trivial (removing check for header.size <= 1).
Comment 7 RHEL Product and Program Management 2011-01-11 15:28:04 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-01-11 17:49:47 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.