Bug 566453 - dual boot corrupted if installation fails
dual boot corrupted if installation fails
Status: CLOSED DUPLICATE of bug 561976
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-18 09:21 EST by Guenni
Modified: 2010-02-18 09:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-18 09:46:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guenni 2010-02-18 09:21:10 EST
Description of problem:

I'm trying to install Fedora 12 as second operating system on a 386 based Laptop.
Windows is already installed and running fine (fault happened with XP and Win7).
There is still unused disk space that shall be used for installation of Fedora.
The installation starts normal and the DVD image is verified before installing 
Fedora. There are no failures detected on the DVD. 

After assigning the remaining disk space to Linux, configuration of grub the 
installation is started. During installation a critical error happens that 
stops the installation (e.g. a library could not be read from DVD). Just the
error log is displayed, no other action is done/possible. The only action I 
can take now is to reboot the Laptop. 

This boot fails as there is no operating system available. Further checks showed that no partition was marked as 'active/bootable' and the MBR might
have been destroyed.

I've had this fault already with Fedora 11.

I don't know if the fault might be related to parted or the parameter passed 
to parted during installation.


Version-Release number of selected component (if applicable):


How reproducible:
I had this every time a Fedora installation was interrupted (by faulty access 
to DVD)

Steps to Reproduce:
1. Running system with other operating system than Linux/Fedora with 
   unallocated disk space to be used for new Fedora installation.
2. Run through installation procedure till software packages are installing
   on the disk (disk partitioning, grub setup, packet selection and dependency 
   check done).
3. Somehow brake the installation with a critical fault so that the 
   installation is aborted (just the error message is displayed, no further 
   action possible).
4. Reboot the PC.

  
Actual results:
 The PC does not start any longer as no active partition is available, MBR
 is destroyed.

Expected results:
 PC should start with the previously installed operating system as this is not
 touched during installation of Fedora.


Additional info:
 IMHO any modification of the MBR and active partition notification on the 
 disk should be executed as the last action of the installation, just before
 a reboot is needed.
Comment 1 Hans de Goede 2010-02-18 09:46:46 EST
What you are seeing is a bug in parted which causes anaconda to overwrite the first and last 9k of the disk, even when (partly) re-using existing partitions.

This was just discovered today, so you have good timing. I've just build a new
parted: parted-2.1-5 for rawhide and F-13 development, which fixes this.

*** This bug has been marked as a duplicate of bug 561976 ***

Note You need to log in before you can comment on or make changes to this bug.