Bug 56647 - ethernet hardware not detected after upgrade
ethernet hardware not detected after upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-23 04:08 EST by Hugh Bragg
Modified: 2015-03-04 20:09 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-29 10:02:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hugh Bragg 2001-11-23 04:08:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; Q312461)

Description of problem:
neat does not detect my network card. It is detected by kudzu correctly, 
but I have tried 2 different cards neither of which is detected by neat. 
The same hardware configuration work for a fresh install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade to RH7.2 from RH6.2
2. run neat
3. attempt to add an ethernet device
	

Actual Results:  The device is not detected and an error message is 
produced:
The Ethernet card could net be initialized. Please verify your settings 
and try again. running ifup eth0 fails.

Expected Results:  Card is detected and the interface is initialised.

Additional info:

The cards are configured correctly and always worked on RH6.2.
Another person with identical hardware has successfully installed RH7.2.
Not even my lo device and routes are not initialised.

using ifup eth0 fails with and error message:
Cannot send dump request: Connection refused

I can configure the interface manually using

ifconfig lo 127.0.0.1/8 up
ifconfig eth0 broadcast 10.3.100.255 10.3.100.53/24 up
route add -net 127.0.0.0/8 lo
route add default gw 10.3.100.1

These ifconfig commands produce error: cannot assign network address
but they work and if run a second time no errors are produced.
everything works fine except the dns updates for the dhcp client on eth0. 
These keep resetting themselves and I must run pump once or twice.

I have tried with a kernel which has only the correct ethernet device 
compiled.
Comment 1 Hugh Bragg 2001-11-26 02:40:27 EST
In the ifup script, I have narrowed the error down to this statement:
[root@rhl etc]# /sbin/ip -o link show eth0
Cannot send dump request: Connection refused
and I get the same result for lo
[root@rhl etc]# /sbin/ip -o link show lo
Cannot send dump request: Connection refused

There is no manual on this command so I don't know how to fix this.
Comment 2 Hugh Bragg 2001-11-26 07:33:41 EST
I solved this problem by compiling kernel netlink user device allowing /sbin/ip 
to run without errors.
I still think this is a bug that should be fixed. My old kernel didn't use the 
netlink device but the new one requires it and the upgrade does not take this 
into account.
Comment 3 Wendy Hung 2001-11-28 11:14:52 EST
Similar bug with Intel EtherExpress Pro 100B after installing RH 7.2
(and upgrading to 2.4.9-13):
Attempted to add network device using GNOME Network Configuration tool.
Received error message:
"The Ethernet card could not be initialized.  Please verify your settings and 
try again."

Disabled adapter, rebooted, and removed configuration in Kudzu.

Re-enabled adapter, rebooted, skipped Kudzu, and tried to add network device.  
Same error message.

Rebooted, configured network using Kudzu.  No problems.
Result:  Adding a network card fails using Network Configuration, but works 
using Kudzu.  







Comment 4 Trond Eivind Glomsrxd 2001-11-28 11:25:41 EST
Can you try the new rpms of redhat-config-network from
http://people.redhat.com/teg/neat/ and see if they help?
Comment 5 Wendy Hung 2001-11-28 12:51:57 EST
I updated to redhat-config-network-0.9.9-0.1 and attempted to add the ethernet 
using Network Configuration.

eth0 automatically appears under the "Devices" tab, but not under "Hardware".
I add the the device under "Hardware" and the error message appears again, but 
eth0 is still added anyways.
Comment 6 Hugh Bragg 2001-11-30 02:34:07 EST
I updated to redhat-config-network-0.9.9-0.1 and attempted to add the ethernet
using Network Configuration too. I got the same result, which is better than
before as the hardware is added now, but still shows the same error message.
Comment 7 Bill Moss 2002-01-17 10:47:31 EST
After a laptop install on a Dell C600 with internal wireless and Xircom 
NIC/Modem, eth0 does not show up under the devices tab but Wireless does. I add 
a three line ifcfg-eth0 file to /etc/sysconfig/network-scripts and then eth0 
shows up in the devices tab and I can configure it. I configured the wireless 
card as eth1. ONBOOT=no in /etc/sysconfig/network-scripts/ifcfg-eth1 does not 
work.
Comment 8 Hugh Bragg 2002-01-18 04:43:42 EST
Still not fixed with redhat-config-network-0.9.10-2
Comment 9 Harald Hoyer 2002-01-18 07:49:30 EST
this is your part, pknirsch :)
Comment 10 Hugh Bragg 2002-01-18 08:52:05 EST
Harold,
Would you mind being a bit more specific.
What exaclty is my part and what can I do to fix it?
Comment 11 Harald Hoyer 2002-01-18 08:56:07 EST
sorry, huge, I meant pknirsch@redhat.com whom you will find on the CC list of 
this bug.
Comment 12 Harald Hoyer 2002-02-20 07:02:19 EST
Ok, the hardware gets detected by scanning /etc/modules.conf.
Normally there are lines like:
alias eth3 3c59x
Which gives redhat-config-network the hint, which card is used for which device.
So could you guys please check, if there are such lines in modules.conf?

Comment 13 Hugh Bragg 2002-02-20 08:25:22 EST
There is such a line in the modules.conf. This may have been added by neat.
alias eth0 3c59x
Problem is I do not use modules for this device.
My hardware driver is compiled into the kernel. I use a 3c905C-TX [Fast
Etherlink] (rev 116).
Since I fixed this manually the device is present and working, but when I try to
detect it, neat reports that the ethernet card could not be initialised and that
I should verify my settings and try again. It adds the interface anyway though,
and it works fine.
My latest kernel is 2.4.9-21 and neat redhat-config-network-0.9.10-2.
Comment 14 Wendy Hung 2002-03-29 10:02:17 EST
System running redhat-config-network-0.9.18-1 and attempted to add the ethernet 
using Network Configuration.  eth0 automatically appears under the "Devices" 
and "Hardware" tabs.  No error message.  eth configured successfully.

redhat-config-network-0.9.20-1.i386.rpm is now available at:
http://people.redhat.com/teg/neat/
Comment 15 Trond Eivind Glomsrxd 2002-04-02 17:07:27 EST
Closing as fixed in response to above comment.

Note You need to log in before you can comment on or make changes to this bug.