Bug 56648 - All games crashed in text console
Summary: All games crashed in text console
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: ace-rhcn   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: bero
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-23 11:04 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 15:52:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-11-23 11:04:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:0.9.3) Gecko/20010808

Description of problem:
If I run games in text console, or my DISPLAY is incorrect
games is crashed

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Close X
2. export DISPLAY=""
3. run any game
	

Actual Results:  Core dumped

Expected Results:  Run propperly

Additional info:

In file table.c
line 267 : display = XOpenDisplay(0);line 268 : screen =
XDefaultScreen(display);
Need
if (display == NULL)
      exit;

Comment 1 Bernhard Rosenkraenzer 2002-01-17 18:36:58 UTC
Closing because Powertools was discontinued and this is not bad enough to
warrant an errata update


Note You need to log in before you can comment on or make changes to this bug.