This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 566511 - Supermin hostfiles lacks wildcard entries
Supermin hostfiles lacks wildcard entries
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-18 12:06 EST by Richard W.M. Jones
Modified: 2010-03-18 18:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: libguestfs-1.0.85-1.el5.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-05 22:45:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-02-18 12:06:49 EST
Description of problem:

$ grep pcre /usr/lib64/guestfs/initramfs.fedora-12.x86_64.supermin.hostfiles 
./lib64/libpcre.so.0
./lib64/libpcre.so.0.0.1    <---

The marked line should be:

./lib64/libpcre.so.0.*

This is correct in my local build, but wrong in the package built on Koji.

Version-Release number of selected component (if applicable):

1.0.84 and others

Additional info:

The build which made this file:

http://koji.fedoraproject.org/koji/buildinfo?buildID=156817

Note that the supermin appliance still works.  However it will be
very fragile because almost any library change will break the
RPM dependencies.
Comment 1 Richard W.M. Jones 2010-03-01 06:59:24 EST
Proposed patch posted upstream:

https://www.redhat.com/archives/libguestfs/2010-March/msg00003.html

and included in Fedora Rawhide build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2021029
Comment 2 Richard W.M. Jones 2010-03-01 08:55:52 EST
Fix for this is now upstream.
Comment 3 Fedora Update System 2010-03-01 15:06:37 EST
libguestfs-1.0.85-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.0.85-1.fc13
Comment 4 Fedora Update System 2010-03-02 09:21:38 EST
libguestfs-1.0.85-1.el5.5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.0.85-1.el5.5
Comment 5 Fedora Update System 2010-03-02 14:17:21 EST
libguestfs-1.0.85-1.fc12.2 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libguestfs-1.0.85-1.fc12.2
Comment 6 Richard W.M. Jones 2010-03-02 14:23:12 EST
The fix in comment 1 didn't fully fix the problem with older
versions of bash.  A newer version of the patch has been
submitted upstream:

https://www.redhat.com/archives/libguestfs/2010-March/msg00005.html
Comment 7 Fedora Update System 2010-03-02 19:19:00 EST
libguestfs-1.0.85-1.el5.5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2010-2332
Comment 8 Fedora Update System 2010-03-02 20:57:16 EST
libguestfs-1.0.85-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-3434
Comment 9 Fedora Update System 2010-03-03 19:05:27 EST
libguestfs-1.0.85-1.fc12.2 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3533
Comment 10 Fedora Update System 2010-03-05 22:45:05 EST
libguestfs-1.0.85-1.fc12.2 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-03-18 18:35:07 EDT
libguestfs-1.0.85-1.el5.5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.