Bug 566562 - lftp doesn't properly implement CCC
Summary: lftp doesn't properly implement CCC
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lftp
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Skala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-18 19:50 UTC by Ray Van Dolson
Modified: 2014-11-09 22:32 UTC (History)
3 users (show)

(edit)
Clone Of: 566561
(edit)
Last Closed: 2010-03-04 13:33:46 UTC


Attachments (Terms of Use)

Description Ray Van Dolson 2010-02-18 19:50:48 UTC
+++ This bug was initially created as a clone of Bug #566561 +++

Description of problem:
lftp does not perform a bi-directional TLS shutdown when used in CCC mode.
Upstream has a patch for this issue that works on the RHEL5 version of
lftp.

Version-Release number of selected component (if applicable):
lftp-4.0.5-1

How reproducible:
Always (for me)

Steps to Reproduce:
1. Set up FTP server that supports CCC (eg ProFTPD 1.3.2)
2. Connect to FTP server using lftp and TLS with the following options:
  - debug 12
  - set ftp:ssl-force true
  - set ftp:ssl-protect-list yes
  - set ftp:ssl-protect-data yes
  - set ftp:ssl-use-ccc yes
3. Connect to the FTP site and attempt a directory listing.
  
Actual results:
Directory listing hangs.  ProFTPD spits out an error similar to:

  Oct 15 19:14:04 mod_tls/2.1.2[14893]: SSL_shutdown error [1]: 
    (1) error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

Expected results:
TLS is shut down and directory listing proceeds normally.

Additional info:
ProFTPD has a bug[1] that mentions this issue.  Also see this[2] thread
from the lftp-devel list which includes a patch that addresses the issue.

[1] http://bugs.proftpd.org/show_bug.cgi?id=2994
[2] http://www.mail-archive.com/lftp-devel%40uniyar.ac.ru/msg01744.html

Comment 1 Ray Van Dolson 2010-02-18 19:52:26 UTC
Assuming lftp releases a new version including this fix, I would like to see
the fix either backported to F11, F12, F13 (since rawhide is now branched),
or the versions in those versions of Fedora rebased to latest.

I can open bugs for those as well if you'd like.

Comment 2 Fedora Update System 2010-03-04 13:48:13 UTC
lftp-4.0.5-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/lftp-4.0.5-2.fc13

Comment 3 Fedora Update System 2010-03-04 13:48:38 UTC
lftp-4.0.5-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/lftp-4.0.5-2.fc12

Comment 4 Fedora Update System 2010-03-04 14:06:18 UTC
lftp-3.7.14-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/lftp-3.7.14-3.fc11

Comment 5 Fedora Update System 2010-03-12 04:24:52 UTC
lftp-4.0.5-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2010-03-23 23:21:20 UTC
lftp-4.0.5-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-03-23 23:29:53 UTC
lftp-3.7.14-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.