Bug 56659 - mkinitrd does not make complete initrd
mkinitrd does not make complete initrd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-23 11:41 EST by Francois-Xavier 'FiX' KOWALSKI
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-27 15:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
An initrd file made by mkinitrd 3.2.6 (4.82 KB, application/octet-stream)
2001-11-27 15:00 EST, Bryan Headley
no flags Details

  None (edit)
Description Francois-Xavier 'FiX' KOWALSKI 2001-11-23 11:41:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5)
Gecko/20011011

Description of problem:
mkinitrd umount the loop-back file system carrying drivers without flushing
it to the file.  this results in a non-usable initrd image at boot time, so
sometimes a boot failure, when the needed scsi driver is part of the modules.

added a "sync" line just before the "umount $MNTPOINT" fixes the problem.

the root cause is maybe located in the loop.c lopp-back driver itself.  the
bug-fix above is just a work-around.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. compile a new kernel (>=2.4.14)
2. install it (make install && make install_modules)
3. attempt to build a new initrd image with mkinitrd
4. reboot.
	

Actual Results:  in case the root fs is located on a scsi device, whose
driver is not built-into the kernel, the boot sequence fails.

Expected Results:  scsi module found in the loopback image & boot successful

Additional info:

I know that RedHat 7.2 usually only carries kernel 2.4.7 by default. 
However, this fix is a matter of improving the robustness of the mkinitrd
script.
Comment 1 Bryan Headley 2001-11-27 15:00:39 EST
Created attachment 38824 [details]
An initrd file made by mkinitrd 3.2.6
Comment 2 Bryan Headley 2001-11-27 15:03:09 EST
An adjunct to the original report. mkinitrd had no problem building 2.4.15's
initrd file. But it failed with 2.4.15-pre1 and beyond. Attached is what it
builds for 2.4.16. I'm going to try Francois-Xavier's suggested patch...
Comment 3 Erik Troan 2002-01-16 15:35:34 EST
Kernel bug; fixed in 2.4.16; never occured in any real Red Hat release.

Note You need to log in before you can comment on or make changes to this bug.