Bug 566619 - X server SEGV's on start if 'nomodeset' used
X server SEGV's on start if 'nomodeset' used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 566931 575654 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-18 19:11 EST by Matthew Woehlke
Modified: 2010-03-29 22:08 EDT (History)
6 users (show)

See Also:
Fixed In Version: xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-29 22:08:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.47 KB, application/octet-stream)
2010-02-18 19:11 EST, Matthew Woehlke
no flags Details
complete Xorg.log (23.66 KB, text/plain)
2010-02-18 19:13 EST, Matthew Woehlke
no flags Details

  None (edit)
Description Matthew Woehlke 2010-02-18 19:11:54 EST
Created attachment 395016 [details]
xorg.conf

Description of problem:
X can't start

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.15-20
(all other packages latest versions as of approx Feb 17)

How reproducible:
Always

Steps to Reproduce:
1. Upgrade from xorg-x11-drv-nouveau-0.0.15-17
2. Reboot
  
Actual results:
X can't start

Expected results:
X starts

Additional info:
(II) NOUVEAU(0): Setting dpms mode 3 on CRTC 0
(II) NOUVEAU(0): Setting dpms mode 3 on CRTC 1
(II) NOUVEAU(0): Setting dpms mode 3 on CRTC 0

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49ec18]
1: /usr/bin/Xorg (0x400000+0x61c29) [0x461c29]
2: /lib64/libpthread.so.0 (0x3909600000+0xf0f0) [0x390960f0f0]
3: /usr/bin/Xorg (dixLookupPrivate+0xa) [0x44605a]
4: /usr/lib64/xorg/modules/libexa.so (exaMarkSync+0x24) [0x7f4c2ffcaf14]
5: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f4c31bf0000+0x20d0f) [0x7f4c31c10d0f]
6: /usr/bin/Xorg (xf86CrtcSetModeTransform+0x385) [0x483935]
7: /usr/bin/Xorg (xf86SetDesiredModes+0x13a) [0x483dba]
8: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f4c31bf0000+0x1ede1) [0x7f4c31c0ede1]
9: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f4c31bf0000+0x1f7bd) [0x7f4c31c0f7bd]
10: /usr/bin/Xorg (AddScreen+0x1d4) [0x4277e4]
11: /usr/bin/Xorg (InitOutput+0x7b4) [0x470064]
12: /usr/bin/Xorg (0x400000+0x21bfa) [0x421bfa]
13: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x3908a1eb1d]
14: /usr/bin/Xorg (0x400000+0x21949) [0x421949]
Segmentation fault at address 0x290

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting
Comment 1 Matthew Woehlke 2010-02-18 19:13:19 EST
Created attachment 395017 [details]
complete Xorg.log
Comment 2 Ben Skeggs 2010-02-21 19:19:45 EST
A couple of questions.  Does -19 (http://koji.fedoraproject.org/koji/buildinfo?buildID=151075) work?  And, any particular reason you have "nomodeset" in your boot options, does it work without that?
Comment 3 Ben Skeggs 2010-02-21 22:59:44 EST
*** Bug 566931 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Woehlke 2010-02-22 13:26:15 EST
Didn't check -19, but -20 started okay without nomodeset. (I'd forgotten I had that; left over from trying to get nvidia to work, since nouveau can't boot my second card :-(. Unfortunately, nvidia dropped support for that card in their new drivers, and it seems the old one doesn't work on F12.)
Comment 5 Charles Dennett 2010-02-22 20:43:29 EST
I can confirm, removing nomodeset from the boot options allows -20 to work.

I don't recall adding nomodeset to the boot options.  In fact I did not know what it did until I googled it.  I built this server a few months ago and installed F12 on it.  At the time I used the on board video.  Perhaps the F12 installation put it there?  M/B is a Biostar TF7100P-M7 and the chipset is GeForce 7150/nForce 630i.
Comment 6 Ben Skeggs 2010-02-23 18:14:07 EST
Can you guys test the build at http://koji.fedoraproject.org/scratch/bskeggs/task_2010361/ and report whether it fixes things?

Thanks!
Comment 7 Fedora Update System 2010-03-14 18:50:24 EDT
xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12
Comment 8 Fedora Update System 2010-03-15 20:33:08 EDT
xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-nouveau'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12
Comment 9 Ben Skeggs 2010-03-21 20:40:12 EDT
*** Bug 575654 has been marked as a duplicate of this bug. ***
Comment 10 Philip Walden 2010-03-22 10:29:18 EDT
I removed nomodeset, rdblacklist=nouveau and vga=0x318 and I can now boot.

I had those set as I had to deal with Bug 555202 until 2.6.32.9-70.fc12.i686.PAE was released. Basically the earlier kernels crashed on my older nvidia card.
Comment 11 Philip Walden 2010-03-22 11:44:24 EDT
I should also point out, that if you are newly installing Fedora 12, you get 2.6.31 and the old nouveau driver. In my case, you are forced to use nomodeset, until the 2.6.32 comes through in the update.
Comment 12 Fedora Update System 2010-03-29 22:08:04 EDT
xorg-x11-drv-nouveau-0.0.15-21.20091105gite1c2efd.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.