Bug 56669 - service foobar disable
service foobar disable
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-23 15:05 EST by Need Real Name
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:21:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-23 15:05:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
it would be /really/ nice being able to do:

# service xinetd disable

instead of using ntsysv, when I want to disable the
running of a service at boot time...
very nice...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.# service xinetd disable


Actual Results:  Usage: /etc/init.d/xinetd 
{start|stop|status|restart|condrestart|reload}


Expected Results:  The service xinetd has been disabled (it will not run 
automatically at boot time)

Additional info:
Comment 1 Bill Nottingham 2001-11-28 01:20:17 EST
Of course, you can always run:

chkconfig --level 345 <service> off
Comment 2 Need Real Name 2001-11-28 07:06:50 EST
yes, I know...
but using the service command will be a /lot/ more intuitive,

(because I'm talking about a *service*, basically I'm saying:
"I want to disable this *service*")

note how I can stop, start, ask status, etc with the command
service, why should I use another command for disabling it ?

of course, this should not be a replace for chkconfig,
because this command may permit more granularity
(user-levels)...
Comment 3 Mike MacCana 2004-02-12 04:13:04 EST
I'm an RHCX, I can certainly say many customers find the name of the 
'chkconfig' tool and the 'service' command's inability to handle 
enabling / diabling services unintuitive.   
Comment 4 Bill Nottingham 2005-09-29 15:21:46 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Realistically, time spent on this is probably better spent on a better service
framework (such as one using dependencies, etc.).

Note You need to log in before you can comment on or make changes to this bug.