Bug 56673 - RMM Header Files Omitted when RMM Library Installed from RPM
RMM Header Files Omitted when RMM Library Installed from RPM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdepim (Show other bugs)
7.2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-23 18:10 EST by Bill Maniatty
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-15 09:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Maniatty 2001-11-23 18:10:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686; Nav)

Description of problem:
When KDEPIM is installed, the librmm module is installed but the header
files are not.
In Redhat 7.1 the include files appeared in /usr/include/rmm/
(e.g. /usr/include/rmm/Envelope.h)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download KNewMail from
http://www.slac.com/mpilone/projects/knewmail.phtml
2.Gunzip and Untar the bundle in a directory
3.Run .configure and then make, and make install
	

Actual Results:  Can't build because rmm/Envelope.h include cannot be
resolved


Expected Results:  Successful build

Additional info:

I was torn asto whether it is a bug or not, and I've decided that it is,
since the
header/include files should be installed with the libarry to promote
software reuse.
I think the include files need to be in the regular rpm, not just the
source rpm for
kdepim.   The 7.1 style packaging was correct in my opinion.

As a work around,  one can
1) unpack the kdepim src and find the rmm include files
2) mkdir /usr/include/rmm directory and
3) copy the header files into it
Comment 1 Petr Rockai 2005-02-15 09:57:02 EST
librmm is no longer part of kdepim and was most probably dropped altogether 

Note You need to log in before you can comment on or make changes to this bug.