Bug 566774 - Cannot unlock after hot-plugging the second monitor
Cannot unlock after hot-plugging the second monitor
Status: CLOSED DUPLICATE of bug 562217
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-19 11:57 EST by Jan "Yenya" Kasprzak
Modified: 2015-01-14 18:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-19 14:53:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2010-02-19 11:57:31 EST
Description of problem:
My laptop is set up to lock the screen when the lid is closed. When I use a beamer, I usually close the lid, walk to the beamer, and plug the VGA cable in. When this happens, the mouse cursor disappears from the screen, and the gnome-screensaver password dialog does not have a focus. So I am unable to unlock the screen.

Moreover, I have found that my password is directed to some random application running on the secondary head (in my case, it was gnome-terminal, and I have been very surprised to have the password visible cleartext there). The only way to unlock the screen is to unplug the beamer (now the cursor reappears, but the password input box still cannot have a focus), click "Cancel" in the password dialog, wait for the dialog to reappear, and then enter the pasword and unlock the screen.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.28.0-8.fc12.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. Have a laptop with display hot-plug working (I have ASUS F3E with the Intel chipset).
2. Set up the screensaver to lock the screen when the lid is closed
3. Close the lid
4. Connect a monitor or beamer to the VGA connector
5. Try to unlock the screen

Actual results:
There is no mouse cursor and nothing can be entered to the password dialog.

Expected results:
The password dialog should still be able to keep the focus.

Additional info:
Comment 1 Ray Strode [halfline] 2010-02-19 14:53:16 EST
Please update to the latest version of gnome-screensaver in updates

*** This bug has been marked as a duplicate of bug 562217 ***

Note You need to log in before you can comment on or make changes to this bug.