Bug 56681 - openssh hangs over wireless network
Summary: openssh hangs over wireless network
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-24 14:39 UTC by Yaron Minsky
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 11:10:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yaron Minsky 2001-11-24 14:39:50 UTC
I just installed a wireless network, and have been experiencing weird
problems with SSH that I presume indicate a bug in SSH itself.  

Basically, SSH connections freeze up, in a not particularly predictable
way.  Sometimes they freeze up almost immediately, although it pretty much
always lets me log in and hit returna  few times.  Starting something big,
like an X client, often causes it to freeze up within a few seconds.  But
sometimes it can go for 20 minutes without freezing.

The freezing usually isn't permanent.  The connection often starts working
again, at least temporarily, in 5-30 minutes.  

With an ethernet connection and the same machines on the same network, this
problem does not reappear.  Wireless networking otherwise works fine,
including long downloads using FTP or red-carpet, and web browsing and all
the rest.

The wireless card I'm using is a Netgear MA401, and the access point is a
Linksys BEFW11S4.  I'm running openssh 2.9p2-9

Comment 1 Nalin Dahyabhai 2002-03-07 21:08:08 UTC
I suspect that there's a network-level problem here, because a TCP connection is
a TCP connection, whether it goes through the air or on a wire.  If you run
"/sbin/ifconfig eth0" (replacing eth0 with the name of the wireless interface),
are you seeing large amounts of packets being lost?

Comment 2 Tomas Mraz 2005-02-03 11:10:41 UTC
This is clearly not an openssh bug.



Note You need to log in before you can comment on or make changes to this bug.