Bug 566842 - [abrt] crash in augeas-0.7.0-1.fc12
[abrt] crash in augeas-0.7.0-1.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: augeas (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
abrt_hash:ed2159bcf7a00cabb0cde34c2a8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-19 17:34 EST by Mike Burns
Modified: 2010-07-22 22:30 EDT (History)
3 users (show)

See Also:
Fixed In Version: augeas-0.7.2-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 15:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.45 KB, text/plain)
2010-02-19 17:34 EST, Mike Burns
no flags Details

  None (edit)
Description Mike Burns 2010-02-19 17:34:24 EST
abrt 1.0.6 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: augtool
comment: Installed augeas and ran with no command line parameters and it immediately seg faulted
component: augeas
executable: /usr/bin/augtool
kernel: 2.6.31.12-174.2.3.fc12.x86_64
package: augeas-0.7.0-1.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.install augeas
2.run augtool with no arguments
3.
Comment 1 Mike Burns 2010-02-19 17:34:26 EST
Created attachment 395190 [details]
File: backtrace
Comment 3 David Lutterkort 2010-02-22 14:52:50 EST
Yes, that very much looks like the same problem. Fix will be in augeas-0.7.1
Comment 4 Fedora Update System 2010-06-30 18:24:49 EDT
augeas-0.7.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/augeas-0.7.2-1.fc12
Comment 5 Fedora Update System 2010-06-30 18:25:43 EDT
augeas-0.7.2-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/augeas-0.7.2-1.el5
Comment 6 Fedora Update System 2010-06-30 18:26:02 EDT
augeas-0.7.2-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/augeas-0.7.2-1.el4
Comment 7 Fedora Update System 2010-06-30 18:26:43 EDT
augeas-0.7.2-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/augeas-0.7.2-2.fc13
Comment 8 Fedora Update System 2010-07-01 14:37:35 EDT
augeas-0.7.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update augeas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/augeas-0.7.2-1.fc12
Comment 9 Fedora Update System 2010-07-01 14:46:40 EDT
augeas-0.7.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update augeas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/augeas-0.7.2-2.fc13
Comment 10 Fedora Update System 2010-07-02 04:58:12 EDT
augeas-0.7.2-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/augeas-0.7.2-3.fc13
Comment 11 Fedora Update System 2010-07-02 15:26:25 EDT
augeas-0.7.2-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update augeas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/augeas-0.7.2-1.el4
Comment 12 Fedora Update System 2010-07-02 15:26:40 EDT
augeas-0.7.2-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update augeas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/augeas-0.7.2-1.el5
Comment 13 Fedora Update System 2010-07-05 18:06:31 EDT
augeas-0.7.2-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update augeas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/augeas-0.7.2-3.fc13
Comment 14 Aaron Faanes 2010-07-10 23:00:33 EDT
augeas-0.7.2-3.fc13 works for me without any arguments. Here's the output of my test below:

[dafrito@fritocomp grub]$ augtool
augtool> ls /files/etc/hosts
#comment = hostname fritocomp added to /etc/hosts by anaconda
1/ = (none)
2/ = (none)
augtool> ls /files/etc/hosts/1
ipaddr = 127.0.0.1
canonical = localhost
alias[1] = localhost.localdomain
alias[2] = localhost4
alias[3] = localhost4.localdomain4
alias[4] = fritocomp
augtool> 
[dafrito@fritocomp grub]$ 

I'd mark this as VERIFIED, but I wasn't able to reproduce the original bug.
Comment 15 Fedora Update System 2010-07-21 15:57:40 EDT
augeas-0.7.2-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2010-07-21 16:03:42 EDT
augeas-0.7.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-07-22 22:29:48 EDT
augeas-0.7.2-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.